aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-11-02 15:53:57 +0800
committerRobert Yang <liezhi.yang@windriver.com>2017-11-22 11:03:31 +0800
commit291a35e7ea98a85e139e9ea0aef44983ec3ad585 (patch)
treed57ddc8039954e2f7eac98f46bd8514413a49c8b
parent9559fe6b95adf5da6051ade3c10189f16976429a (diff)
downloadopenembedded-core-contrib-291a35e7ea98a85e139e9ea0aef44983ec3ad585.tar.gz
volatile-binds: use PN to replace hardcode name
Otherwise it doesn't work since SYSTEMD_SERVICE_volatile-binds is not defined when multilib. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-core/volatile-binds/volatile-binds.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/volatile-binds/volatile-binds.bb b/meta/recipes-core/volatile-binds/volatile-binds.bb
index a6e3254930..d861a71a6b 100644
--- a/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -67,7 +67,7 @@ do_install () {
install -m 0755 mount-copybind ${D}${base_sbindir}/
install -d ${D}${systemd_unitdir}/system
- for service in ${SYSTEMD_SERVICE_volatile-binds}; do
+ for service in ${SYSTEMD_SERVICE_${PN}}; do
install -m 0644 $service ${D}${systemd_unitdir}/system/
done