aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 15:58:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 13:34:51 +0100
commit0ea24447842e6b76ccfee0881f557e1a82e89ef1 (patch)
tree4b9363da4c00f28e62a3ff16543027a82be0cd8c
parent936e2868bb9973213630477ab9c880dbdf4aac09 (diff)
downloadopenembedded-core-contrib-0ea24447842e6b76ccfee0881f557e1a82e89ef1.tar.gz
autotools: Use STAGING_DATADIR_NATIVE for config.rpath
For builds that don't use gettext, config.rpath may not exist in the target datadir. This change uses the native directory where it will always be present due to gettext-minimal-native (which allows us to autoreconf recipes using gettext even if we don't have gettext built). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/autotools.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 59c5bae8fa..b97d74b8d1 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -175,9 +175,9 @@ autotools_do_configure() {
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
# We'd call gettextize here if it wasn't so broken...
- cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
+ cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
if [ -d ${S}/po/ ]; then
- cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
+ cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
fi
for i in gettext.m4 iconv.m4 lib-ld.m4 lib-link.m4 lib-prefix.m4 nls.m4 po.m4 progtest.m4; do
for j in `find ${S} -name $i | grep -v aclocal-copy`; do