aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-26 09:58:35 +0800
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:55:58 -0700
commit6e1b17f19411ed897c53ae0ef41a2d2972a9c113 (patch)
tree96e61c91a61120bb8c6b5e327cc81c85c8e552c4
parent6b3bd34bf8c5e511bccfbb64bdd1236e1e7576e3 (diff)
downloadopenembedded-core-contrib-6e1b17f19411ed897c53ae0ef41a2d2972a9c113.tar.gz
autotools.bbclass: force copy Makefile.in.in to ${S}/po/
If a Makefile.in.in has existed under ${S}/po/ and is read-only, cp will fail. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 66c0f5d10a..4e4ef986bf 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -201,7 +201,7 @@ autotools_do_configure() {
# We'd call gettextize here if it wasn't so broken...
cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
if [ -d ${S}/po/ ]; then
- cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
+ cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
if [ ! -e ${S}/po/remove-potcdate.sin ]; then
cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/
fi