aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-09-22 03:56:29 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-24 17:52:46 +0100
commit8572b883730d68fa2e9bc46375383f5f1edfae7e (patch)
tree5a2a5723572d4e37fada99cc081efd54d709ff06
parent564a114a72d223e9445139394a8d2574c7af98df (diff)
downloadopenembedded-core-contrib-8572b883730d68fa2e9bc46375383f5f1edfae7e.tar.gz
systemd: disable problematic GCC 5.2 optimizations
This fixes systemd failing to start on Raspberry Pi 2 if it is compiled with GCC 5.2. It would try to start "Journal Service" and "udev Kernel Device Manager" but fail repeatedly. [YOCTO #8291] Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_225.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_225.bb b/meta/recipes-core/systemd/systemd_225.bb
index f7d4c7df48..fd1a3f315a 100644
--- a/meta/recipes-core/systemd/systemd_225.bb
+++ b/meta/recipes-core/systemd/systemd_225.bb
@@ -123,6 +123,9 @@ EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
# uclibc does not have NSS
EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
+# disable problematic GCC 5.2 optimizations [YOCTO #8291]
+FULL_OPTIMIZATION_append_arm = " -fno-schedule-insns -fno-schedule-insns2"
+
do_configure_prepend() {
export NM="${HOST_PREFIX}gcc-nm"
export AR="${HOST_PREFIX}gcc-ar"