summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-10-15 14:29:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-17 12:33:30 +0100
commit5039d313df6cb2c477766ada936806e4ffd5a8ec (patch)
treeb49a214b323abf70590ac3bfa7f6a97252318570
parent14c3454db0108ff78b73eecfae179a69241d9f5c (diff)
downloadopenembedded-core-contrib-5039d313df6cb2c477766ada936806e4ffd5a8ec.tar.gz
dhcpcd: add PACKAGECONFIG for ntp/chrony/ypbind hooks
By default, the dhcpcd will search ntp/chrony/ypbind in host path when configuring and install the hooks once it find them. Add PACKAGECONFIG for these hooks to avoid the host contamination. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb b/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
index 4344841b54..13467189b4 100644
--- a/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
+++ b/meta/recipes-connectivity/dhcpcd/dhcpcd_9.2.0.bb
@@ -27,10 +27,18 @@ PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
+# ntp conflicts with chrony
+PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
+PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
+PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
EXTRA_OECONF = "--enable-ipv4 \
--dbdir=${localstatedir}/lib/${BPN} \
--runstatedir=/run \
+ --enable-privsep \
+ --privsepuser=dhcpcd \
+ --with-hooks \
+ --with-eghooks \
"
USERADD_PACKAGES = "${PN}"