aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2014-08-08 14:11:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-12 13:50:31 +0100
commit632faca3b884ebe155847db96525d6f8a78dbd99 (patch)
treeea6559cea145a7366a7f4d426ccf73c2d5a9018f
parentcb5c70dd358328aebe71956ca7b32345e59baad0 (diff)
downloadopenembedded-core-contrib-632faca3b884ebe155847db96525d6f8a78dbd99.tar.gz
bsp-guide: Applied the <replaceable> tag as needed.
(From yocto-docs rev: 6f8f374f3f7f70082c7bc45c1715324214dc2099) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/bsp-guide/bsp.xml80
1 files changed, 40 insertions, 40 deletions
diff --git a/documentation/bsp-guide/bsp.xml b/documentation/bsp-guide/bsp.xml
index fd143ede14..482f2ebe7f 100644
--- a/documentation/bsp-guide/bsp.xml
+++ b/documentation/bsp-guide/bsp.xml
@@ -37,7 +37,7 @@
Although not a strict requirement, layers in the Yocto Project use the
following well established naming convention:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;
+ meta-<replaceable>bsp_name</replaceable>
</literallayout>
The string "meta-" is prepended to the machine or platform name, which is
"bsp_name" in the above form.
@@ -50,7 +50,7 @@
<ulink url='&YOCTO_DOCS_DEV_URL;#yocto-project-repositories'>Yocto Project Source Repositories</ulink>
through a web interface at
<ulink url='&YOCTO_GIT_URL;/cgit/cgit.cgi'></ulink>.
- If you go to that interface you will find near the bottom of the list
+ If you go to that interface, you will find near the bottom of the list
under "Yocto Metadata Layers" several BSP layers all of which are
supported by the Yocto Project (e.g. <filename>meta-minnow</filename>,
<filename>meta-raspberrypi</filename>, and
@@ -72,7 +72,7 @@
</para>
<para>
- The layer's base directory (<filename>meta-&lt;bsp_name&gt;</filename>) is the root
+ The layer's base directory (<filename>meta-<replaceable>bsp_name</replaceable></filename>) is the root
of the BSP Layer.
This root is what you add to the
<ulink url='&YOCTO_DOCS_REF_URL;#var-BBLAYERS'><filename>BBLAYERS</filename></ulink>
@@ -175,17 +175,17 @@
for specific BSPs could differ.
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/
- meta-&lt;bsp_name&gt;/&lt;bsp_license_file&gt;
- meta-&lt;bsp_name&gt;/README
- meta-&lt;bsp_name&gt;/README.sources
- meta-&lt;bsp_name&gt;/binary/&lt;bootable_images&gt;
- meta-&lt;bsp_name&gt;/conf/layer.conf
- meta-&lt;bsp_name&gt;/conf/machine/*.conf
- meta-&lt;bsp_name&gt;/recipes-bsp/*
- meta-&lt;bsp_name&gt;/recipes-core/*
- meta-&lt;bsp_name&gt;/recipes-graphics/*
- meta-&lt;bsp_name&gt;/recipes-kernel/linux/linux-yocto_&lt;kernel_rev&gt;.bbappend
+ meta-<replaceable>bsp_name</replaceable>/
+ meta-<replaceable>bsp_name</replaceable>/<replaceable>bsp_license_file</replaceable>
+ meta-<replaceable>bsp_name</replaceable>/README
+ meta-<replaceable>bsp_name</replaceable>/README.sources
+ meta-<replaceable>bsp_name</replaceable>/binary/<replaceable>bootable_images</replaceable>
+ meta-<replaceable>bsp_name</replaceable>/conf/layer.conf
+ meta-<replaceable>bsp_name</replaceable>/conf/machine/*.conf
+ meta-<replaceable>bsp_name</replaceable>/recipes-bsp/*
+ meta-<replaceable>bsp_name</replaceable>/recipes-core/*
+ meta-<replaceable>bsp_name</replaceable>/recipes-graphics/*
+ meta-<replaceable>bsp_name</replaceable>/recipes-kernel/linux/linux-yocto_<replaceable>kernel_rev</replaceable>.bbappend
</literallayout>
</para>
@@ -221,7 +221,6 @@
meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend
meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
meta-crownbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
- meta-crownbay/recipes-kernel/linux/linux-yocto_3.14.bbappend
</literallayout>
</para>
@@ -235,7 +234,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/&lt;bsp_license_file&gt;
+ meta-<replaceable>bsp_name</replaceable>/<replaceable>bsp_license_file</replaceable>
</literallayout>
</para>
@@ -257,7 +256,7 @@
<para>
You can find this file in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/README
+ meta-<replaceable>bsp_name</replaceable>/README
</literallayout>
</para>
@@ -281,7 +280,7 @@
<para>
You can find this file in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/README.sources
+ meta-<replaceable>bsp_name</replaceable>/README.sources
</literallayout>
</para>
@@ -300,7 +299,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/binary/&lt;bootable_images&gt;
+ meta-<replaceable>bsp_name</replaceable>/binary/<replaceable>bootable_images</replaceable>
</literallayout>
</para>
@@ -316,7 +315,7 @@
<para>
The exact types of binaries present are highly hardware-dependent.
- However, a README file should be present in the BSP Layer that explains how to use
+ However, a <filename>README</filename> file should be present in the BSP Layer that explains how to use
the kernels and images with the target hardware.
If pre-built binaries are present, source code to meet licensing requirements must also
exist in some form.
@@ -328,7 +327,7 @@
<para>
You can find this file in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/conf/layer.conf
+ meta-<replaceable>bsp_name</replaceable>/conf/layer.conf
</literallayout>
</para>
@@ -338,9 +337,9 @@
contents of the layer, and contains information about how the build
system should use it.
Generally, a standard boilerplate file such as the following works.
- In the following example, you would replace "<filename>bsp</filename>" and
- "<filename>_bsp</filename>" with the actual name
- of the BSP (i.e. <filename>&lt;bsp_name&gt;</filename> from the example template).
+ In the following example, you would replace "<replaceable>bsp</replaceable>" and
+ "<replaceable>_bsp</replaceable>" with the actual name
+ of the BSP (i.e. <replaceable>bsp_name</replaceable> from the example template).
</para>
<para>
@@ -381,7 +380,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/conf/machine/*.conf
+ meta-<replaceable>bsp_name</replaceable>/conf/machine/*.conf
</literallayout>
</para>
@@ -441,7 +440,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/recipes-bsp/*
+ meta-<replaceable>bsp_name</replaceable>/recipes-bsp/*
</literallayout>
</para>
@@ -478,7 +477,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/recipes-graphics/*
+ meta-<replaceable>bsp_name</replaceable>/recipes-graphics/*
</literallayout>
</para>
@@ -502,7 +501,7 @@
<para>
You can find these files in the BSP Layer at:
<literallayout class='monospaced'>
- meta-&lt;bsp_name&gt;/recipes-kernel/linux/linux-yocto_*.bbappend
+ meta-<replaceable>bsp_name</replaceable>/recipes-kernel/linux/linux-yocto_*.bbappend
</literallayout>
</para>
@@ -515,13 +514,13 @@
at <filename>meta/recipes-kernel/linux</filename>.
You can append your specific changes to the kernel recipe by using a
similarly named append file, which is located in the BSP Layer (e.g.
- the <filename>meta-&lt;bsp_name&gt;/recipes-kernel/linux</filename> directory).
+ the <filename>meta-<replaceable>bsp_name</replaceable>/recipes-kernel/linux</filename> directory).
</para>
<para>
Suppose you are using the <filename>linux-yocto_3.10.bb</filename> recipe to build
the kernel.
In other words, you have selected the kernel in your
- <filename>&lt;bsp_name&gt;.conf</filename> file by adding these types
+ <replaceable>bsp_name</replaceable><filename>.conf</filename> file by adding these types
of statements:
<literallayout class='monospaced'>
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
@@ -530,7 +529,7 @@
<note>
When the preferred provider is assumed by default, the
<filename>PREFERRED_PROVIDER</filename> statement does not appear in the
- <filename>&lt;bsp_name&gt;.conf</filename> file.
+ <replaceable>bsp_name</replaceable><filename>.conf</filename> file.
</note>
You would use the <filename>linux-yocto_3.10.bbappend</filename> file to append
specific BSP settings to the kernel, thus configuring the kernel for your particular BSP.
@@ -752,7 +751,7 @@
</para></listitem>
<listitem><para><emphasis>License File:</emphasis>
You must include a license file in the
- <filename>meta-&lt;bsp_name&gt;</filename> directory.
+ <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
This license covers the BSP Metadata as a whole.
You must specify which license to use since there is no
default license if one is not specified.
@@ -762,7 +761,7 @@
as an example.</para></listitem>
<listitem><para><emphasis>README File:</emphasis>
You must include a <filename>README</filename> file in the
- <filename>meta-&lt;bsp_name&gt;</filename> directory.
+ <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
See the
<ulink url='&YOCTO_GIT_URL;/cgit.cgi/meta-intel/tree/meta-fri2/README'><filename>README</filename></ulink>
file for the Fish River Island 2 BSP in the <filename>meta-fri2</filename> BSP layer
@@ -804,7 +803,7 @@
</itemizedlist></para></listitem>
<listitem><para><emphasis>README.sources File:</emphasis>
You must include a <filename>README.sources</filename> in the
- <filename>meta-&lt;bsp_name&gt;</filename> directory.
+ <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
This file specifies exactly where you can find the sources used to
generate the binary images contained in the
<filename>binary</filename> directory, if present.
@@ -814,12 +813,13 @@
as an example.</para></listitem>
<listitem><para><emphasis>Layer Configuration File:</emphasis>
You must include a <filename>conf/layer.conf</filename> in the
- <filename>meta-&lt;bsp_name&gt;</filename> directory.
- This file identifies the <filename>meta-&lt;bsp_name&gt;</filename>
+ <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
+ This file identifies the <filename>meta-<replaceable>bsp_name</replaceable></filename>
BSP layer as a layer to the build system.</para></listitem>
<listitem><para><emphasis>Machine Configuration File:</emphasis>
- You must include one or more <filename>conf/machine/&lt;bsp_name&gt;.conf</filename>
- files in the <filename>meta-&lt;bsp_name&gt;</filename> directory.
+ You must include one or more
+ <filename>conf/machine/<replaceable>bsp_name</replaceable>.conf</filename>
+ files in the <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
These configuration files define machine targets that can be built
using the BSP layer.
Multiple machine configuration files define variations of machine
@@ -866,7 +866,7 @@
filesystems meant to allow users to boot the BSP for evaluation
purposes, you should put the images and artifacts within a
<filename>binary/</filename> subdirectory located in the
- <filename>meta-&lt;bsp_name&gt;</filename> directory.
+ <filename>meta-<replaceable>bsp_name</replaceable></filename> directory.
<note>If you do include a bootable image as part of the BSP and the image
was built by software covered by the GPL or other open source licenses,
it is your responsibility to understand
@@ -1100,7 +1100,7 @@
Consequently, to use the scripts, you must <filename>source</filename> the
environment just as you would when invoking a build:
<literallayout class='monospaced'>
- $ source oe-init-build-env [build_dir]
+ $ source oe-init-build-env <replaceable>build_dir</replaceable>
</literallayout>
</para>