aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-23 12:10:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-03 14:55:42 +0100
commit330c3085317a0b0981163ff5c41c54596e0d127d (patch)
tree1a0f4c35414716b32bb0e20ba03658b46491f9fb
parenta6f79561f7a2f6bc354d5ea8d84b836ac5c9b08f (diff)
downloadopenembedded-core-contrib-330c3085317a0b0981163ff5c41c54596e0d127d.tar.gz
libtool-cross/native: Force usage of bash due to sstate inconsistencies
Scenario: a) libtool script is built on system with bash as /bin/sh b) machine B installs sstate from build a) c) machine B has dash as /bin/sh In this scenario, the script fails to work properly since its expecting /bin/sh to have bash like syntax and it no longer does have it. This patch forces the configure process to use /bin/bash, not /bin/sh and hence allows the scripts to work correctly when used from sstate. (From OE-Core rev: 24d5b449e5f4d91119f0d8e13c457618811aadfc) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb2
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb1
2 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
index 34aae0bf13..72fad37eaf 100644
--- a/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
@@ -39,3 +39,5 @@ libtoolcross_sysroot_preprocess () {
}
SSTATE_SCAN_FILES += "libtoolize *-libtool"
+
+export CONFIG_SHELL="/bin/bash"
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
index df73f08e99..f1051d84f3 100644
--- a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -22,3 +22,4 @@ do_install () {
install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
}
+export CONFIG_SHELL="/bin/bash"