summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2022-07-01 07:01:17 -1000
committerSteve Sakoman <steve@sakoman.com>2022-07-07 06:42:41 -1000
commite863fc060940d11cd6fd58f0f314333ed419cf54 (patch)
tree050382cbb3cbed492b6f48974ba668138300c04d
parent70b3c7004e8f14a99adf6119f153a08ec4a4bc6b (diff)
downloadopenembedded-core-contrib-e863fc060940d11cd6fd58f0f314333ed419cf54.tar.gz
openssh: break dependency on base package for -dev package
Otherwise the SDK fails to build as the main openssh and dropbear packages conflict with each other Signed-off-by: Steve Sakoman <steve@sakoman.com> (cherry picked from commit f90647e9dd95cfd29b5bdb8d7dcd688a10fc060c) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-connectivity/openssh/openssh_8.2p1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_8.2p1.bb b/meta/recipes-connectivity/openssh/openssh_8.2p1.bb
index eaec26cac0..c529d1d060 100644
--- a/meta/recipes-connectivity/openssh/openssh_8.2p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_8.2p1.bb
@@ -196,6 +196,11 @@ RRECOMMENDS_${PN}-sshd_append_class-target = "\
${@bb.utils.filter('PACKAGECONFIG', 'rng-tools', d)} \
"
+# break dependency on base package for -dev package
+# otherwise SDK fails to build as the main openssh and dropbear packages
+# conflict with each other
+RDEPENDS:${PN}-dev = ""
+
# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
RDEPENDS_${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils"