summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-27 06:44:40 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-11-27 06:44:40 -0800
commitd44de2beb1e6cf1a798ebb75250145ecdeafa3fd (patch)
treedf7929e82a1ce92e51d9e1614d2834762e306631
parent84906e61a9ae8d824a1fa338eeadc01377470157 (diff)
downloadopenembedded-core-contrib-d44de2beb1e6cf1a798ebb75250145ecdeafa3fd.tar.gz
python-async: use pypi.bbclass
* Simplify by using pypi.bbclass * Use PYTHON_PN for RDEPENDS in .inc to avoid duplication Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-async.inc5
-rw-r--r--meta/recipes-devtools/python/python3-async_0.6.2.bb3
2 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-async.inc b/meta/recipes-devtools/python/python-async.inc
index 2c5cb4d191..56e9592ac0 100644
--- a/meta/recipes-devtools/python/python-async.inc
+++ b/meta/recipes-devtools/python/python-async.inc
@@ -4,12 +4,11 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
-SRC_URI = "https://files.pythonhosted.org/packages/source/a/async/async-${PV}.tar.gz"
SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/async/"
+inherit pypi
-S = "${WORKDIR}/async-${PV}"
+RDEPENDS_${PN} += "${PYTHON_PN}-threading"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-async_0.6.2.bb b/meta/recipes-devtools/python/python3-async_0.6.2.bb
index f45781c44f..e62b21fcae 100644
--- a/meta/recipes-devtools/python/python3-async_0.6.2.bb
+++ b/meta/recipes-devtools/python/python3-async_0.6.2.bb
@@ -1,6 +1,3 @@
require python-async.inc
inherit setuptools3
-
-RDEPENDS_${PN} += "python3-threading"
-