summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Baryshkov <dmitry.baryshkov@linaro.org>2020-12-11 17:28:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-14 00:08:38 +0000
commit3c72feede4aea5538313b11d06d95f69e80cef03 (patch)
treef249cdfc9af4f1cb6ab0f2c474ee7180811ba954
parentc8c7a4fe2027ff697b5b7a7249a2dd32f40eb47e (diff)
downloadopenembedded-core-contrib-3c72feede4aea5538313b11d06d95f69e80cef03.tar.gz
perl: fix installation failure because of shell issue
On one of my buildservers I noticed perl do_install failing with the following message: | rm: cannot remove '<OEROOT>/tmp-rpb-glibc/work/armv8-2a-linaro-linux/perl/5.32.0-r0/image//usr/lib/perl5/5.32.0/*/CORE/libperl.so': No such file or directory I tracked this down to shell being dash rather than bash not being able to expand this glob in the middle of the filename. So replace the glob expansion with the simpler one which works in all cases. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.0.bb b/meta/recipes-devtools/perl/perl_5.32.0.bb
index bba8263b90..3815dd44b1 100644
--- a/meta/recipes-devtools/perl/perl_5.32.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.0.bb
@@ -137,8 +137,9 @@ do_install() {
install lib/ExtUtils/typemap ${D}${libdir}/perl5/${PV}/ExtUtils/
# Fix up shared library
- rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
- ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
+ dir=$(echo ${D}/${libdir}/perl5/${PV}/*/CORE)
+ rm $dir/libperl.so
+ ln -sf ../../../../libperl.so.${PERL_LIB_VER} $dir/libperl.so
# Try to catch Bug #13946
if [ -e ${D}/${libdir}/perl5/${PV}/Storable.pm ]; then