summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2019-06-06 10:02:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-07 09:10:34 +0100
commit03e3721674fe7fc22911ec738524cef86c7a5357 (patch)
tree5a6699ca455bde99c6d9e0f88dab8e5ffd6ea9bb
parent1208ff934a2bb6378aa8b219345110a0d56bf767 (diff)
downloadopenembedded-core-contrib-03e3721674fe7fc22911ec738524cef86c7a5357.tar.gz
slang: modify an array test
One array test attempts to create an array that is far too large to exist. Different exceptions are thrown for 32 and 64 bit machines, so we account for that when catching them. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/slang/slang/array_test.patch20
-rw-r--r--meta/recipes-extended/slang/slang_2.3.2.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang/array_test.patch b/meta/recipes-extended/slang/slang/array_test.patch
new file mode 100644
index 0000000000..ccd416f207
--- /dev/null
+++ b/meta/recipes-extended/slang/slang/array_test.patch
@@ -0,0 +1,20 @@
+slang: modify array test
+
+One array test tries to create an array that is far too large and anticipates an exception.
+IndexError will only be thrown for 64 bit machines, so we add InvalidParmError for 32 bit ones.
+
+Upstream-Status: Submitted [jedsoft.org]
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
+--- a/src/test/array.sl
++++ b/src/test/array.sl
+@@ -165,7 +165,7 @@ try
+ {
+ SS = Long_Type[10000,10000,10000,10000,10000,10000];
+ }
+-catch IndexError;
++catch IndexError,InvalidParmError;
+
+ private define array_map2_func ()
+ {
diff --git a/meta/recipes-extended/slang/slang_2.3.2.bb b/meta/recipes-extended/slang/slang_2.3.2.bb
index e329310937..99efb16da6 100644
--- a/meta/recipes-extended/slang/slang_2.3.2.bb
+++ b/meta/recipes-extended/slang/slang_2.3.2.bb
@@ -19,6 +19,7 @@ SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \
file://dont-link-to-host.patch \
file://test-add-output-in-the-format-result-testname.patch \
file://terminfo_fixes.patch \
+ file://array_test.patch \
file://run-ptest \
"