summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-08-30 14:27:35 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-04 11:03:31 +0100
commit165da89292f81d236e4e8e652500b8879c2ad9be (patch)
tree881bbdeb850de6b2a0f61ad8a8da34d4ef34c242
parent1e75fead42f27723e720686f5a5233dc5acbe5b3 (diff)
downloadopenembedded-core-contrib-165da89292f81d236e4e8e652500b8879c2ad9be.tar.gz
go-dep: Update 0.4.1 -> 0.5.0
NEW FEATURES: - Add CI tests against go1.10. Drop support for go1.8. (#1620). - Added install.sh script. (#1533). - List out of date projects in dep status (#1553). - Enabled opt-in persistent caching via DEPCACHEAGE env var. (#1711). - Allow DEPPROJECTROOT environment variable to supersede GOPATH deduction and explicitly set the current project's root (#1883). - dep ensure now explains what changes to the code or Gopkg.toml have induced solving (#1912). - Hash digests of vendor contents are now stored in Gopkg.lock, and the contents of vendor are only rewritten on change or hash mismatch (#1912). - Added support for ppc64/ppc64le. - New subcommand dep check quickly reports if imports, Gopkg.toml, Gopkg.lock, and vendor are out of sync (#1932). BUG FIXES: - Excise certain git-related environment variables. (#1872) IMPROVEMENTS: - Add template operations support in dep status template output (#1549). - Reduce network access by trusting local source information and only pulling from upstream when necessary (#1250). - Update our dependency on Masterminds/semver to follow upstream again now that Masterminds/semver#67 is merged(#1792). - inputs-digest was removed from Gopkg.lock (#1912). - Hash digests of vendor contents are now stored in Gopkg.lock, and the contents of vendor are only rewritten on change or hash mismatch (#1912). - Don't exclude Godeps folder (#1822). - Add project-package relationship graph support in graphviz (#1588). - Limit concurrency of dep status to avoid hitting open file limits (#1923). Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/go/go-dep_0.5.0.bb (renamed from meta/recipes-devtools/go/go-dep_0.4.1.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.4.1.bb b/meta/recipes-devtools/go/go-dep_0.5.0.bb
index 10af1d660c..f0ce60a8ec 100644
--- a/meta/recipes-devtools/go/go-dep_0.4.1.bb
+++ b/meta/recipes-devtools/go/go-dep_0.5.0.bb
@@ -8,8 +8,8 @@ SRC_URI = "git://${GO_IMPORT} \
file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
"
-# Points to 0.4.1 tag
-SRCREV = "37d9ea0ac16f0e0a05afc3b60e1ac8c364b6c329"
+# Points to 0.5.0 tag
+SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978"
inherit go