summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-15 15:30:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-18 23:09:23 +0100
commit3ba37063ac08c71cdaba07e9b85ee3246c6f1350 (patch)
treed3c8d2653931a3815072c49cfa6b9ed4f393e12e
parenta365cd7a358db96791033e6dc6e45d2e816d3e4c (diff)
downloadopenembedded-core-contrib-3ba37063ac08c71cdaba07e9b85ee3246c6f1350.tar.gz
linux-yocto/5.13: add devupstream support
We are always getting questions about building -stable, or mainline master. Rather than introducing a separate set of recipes, we can facilitate this sort of usecase by using the existing devupstream bbclass support. To build an unpatched or otherwise modifed -stable of 5.13, simply set the linux-yocto preferred provider to: linux-yocto-upstream and the PREFERRED_VERSION_linux-yocto-upstream to one with support. And your wish will be granted, as the build will use v5.13/base which matches the main linux-yocto version, simply with no extra changes applied. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.13.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.13.bb b/meta/recipes-kernel/linux/linux-yocto_5.13.bb
index 66384d8f7d..74699d03ae 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.13.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.13.bb
@@ -25,6 +25,16 @@ SRCREV_machine_qemumips64 ?= "b74fe3dcca0653609fcb75aad883b1db07619081"
SRCREV_machine ?= "b1cead8d98582ca687f93e06438543b97144e5bf"
SRCREV_meta ?= "ceb5fa598d08902fe2934c041875aa92d9a6fa19"
+# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
+# get the <version>/base branch, which is pure upstream -stable, and the same
+# meta SRCREV as the linux-yocto-standard builds. Select your version using the
+# normal PREFERRED_VERSION settings.
+BBCLASSEXTEND = "devupstream:target"
+DEFAULT_PREFERENCE_class-devupstream = "-1"
+SRCREV_class-devupstream = "62fb9874f5da54fdb243003b386128037319b219"
+PN_class-devupstream = "linux-yocto-upstream"
+KBRANCH_class-devupstream = "v5.13/base"
+
# remap qemuarm to qemuarma15 for the 5.8 kernel
# KMACHINE_qemuarm ?= "qemuarma15"