summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-15 15:37:21 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 10:31:37 +0000
commit3da6a4151ed3d69595548931a86a64268be55749 (patch)
treef5a1220cc1b49488721610cbcdb33ffcbc72c50b
parent12f03dda0cb339be16261da205f0aa0ec976bfc8 (diff)
downloadopenembedded-core-contrib-3da6a4151ed3d69595548931a86a64268be55749.tar.gz
python3-setuptools-rust-native: use setuptools_build_meta
The wheel generation problems are solved now: a wheel is correctly built to setuptools_rust-1.1.2-py3-none-any.whl, so we can use setuptools_build_meta. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb b/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
index 2b92972700..bac7b6434a 100644
--- a/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
+++ b/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
@@ -12,10 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz"
SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1"
-# While this has a pyproject.toml and declares that setuptools_build_meta should work
-# it results in a wheel named UNKNOWN-0.0.0-py3-none-any.whl so stay with setuptools3
-# until that can be resolved
-inherit cargo pypi setuptools3 native
+inherit cargo pypi setuptools_build_meta native
DEPENDS += "python3-setuptools-scm-native python3-wheel-native"