summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-09 11:50:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-10 09:48:44 +0100
commit5f01497dee9fcd5e5fc6bddb061b6cc55909fe65 (patch)
treefbe1a019329f605a6e9e37b9555d731012a28728
parent78fcea74517de4793cc0ecc97bce7f5c7dcd44c0 (diff)
downloadopenembedded-core-contrib-5f01497dee9fcd5e5fc6bddb061b6cc55909fe65.tar.gz
libsndfile1: disable use of sqlite3 by default
sqlite3 is only used by the regression testing tool, which is of limited use unless you're the developer of libsndfile. Add a PACKAGECONFIG for this, but disable by default. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/libsndfile/libsndfile1_1.0.28.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.28.bb b/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.28.bb
index 77393db847..7dfee4e96f 100644
--- a/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.28.bb
+++ b/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.28.bb
@@ -1,7 +1,7 @@
SUMMARY = "Audio format Conversion library"
HOMEPAGE = "http://www.mega-nerd.com/libsndfile"
AUTHOR = "Erik de Castro Lopo"
-DEPENDS = "flac libogg libvorbis sqlite3"
+DEPENDS = "flac libogg libvorbis"
SECTION = "libs/multimedia"
LICENSE = "LGPLv2.1"
@@ -30,6 +30,7 @@ S = "${WORKDIR}/libsndfile-${PV}"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
+PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3"
inherit autotools lib_package pkgconfig