summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-11 13:38:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:48:23 +0000
commit8a497ef5eb3b54ed45b826fec910ed61985e04ce (patch)
tree664396d09a00f8a49019d2cfc25b3fe8fe3f40bc
parent3e6f57059d1a5343fe1432fba408ee3f33b4c2f7 (diff)
downloadopenembedded-core-contrib-8a497ef5eb3b54ed45b826fec910ed61985e04ce.tar.gz
libsdl2: require GLES when building Wayland support
The Wayland support requires GLES2 to be enabled as otherwise the EGL support code in SDL2 isn't enabled. | In file included from .../SDL2-2.0.3/src/video/wayland/SDL_waylandvideo.c:34:0: | .../SDL2-2.0.3/src/video/wayland/SDL_waylandvideo.c: In function 'Wayland_CreateDevice': | .../SDL2-2.0.3/src/video/wayland/SDL_waylandopengles.h:38:38: error: 'SDL_EGL_GetSwapInterval' undeclared (first use in this function) | #define Wayland_GLES_GetSwapInterval SDL_EGL_GetSwapInterval Solve this by adding gles2 to the Wayland PACKAGECONFIG option. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
index 97f64f3847..f138f9761d 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
@@ -39,7 +39,7 @@ PACKAGECONFIG ??= " \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
"
PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"