summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 13:38:23 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 13:38:23 +0000
commit98eb6feeb643977694ddd8ba88bf35f9df114d26 (patch)
treeab882a607228742d008c8902f58d24ba0f539f36
parent2f3ca937d66ce6b9f2bdb1c09fbf066818ac92f4 (diff)
downloadopenembedded-core-contrib-98eb6feeb643977694ddd8ba88bf35f9df114d26.tar.gz
python-native: added forgotten patches
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4173 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch18
-rw-r--r--meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch36
-rw-r--r--meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch13
-rw-r--r--meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch16
4 files changed, 83 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch b/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch
new file mode 100644
index 0000000000..999bddc449
--- /dev/null
+++ b/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch
@@ -0,0 +1,18 @@
+
+#
+# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200
++++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100
+@@ -78,8 +78,8 @@
+ exec_prefix= @exec_prefix@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch b/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch
new file mode 100644
index 0000000000..3356c1abbe
--- /dev/null
+++ b/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100
++++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100
+@@ -19,8 +19,8 @@
+ from errors import DistutilsPlatformError
+
+ # These are needed in a couple of spots, so just compute them once.
+-PREFIX = os.path.normpath(sys.prefix)
+-EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
++PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
++EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+ # python_build: (Boolean) if true, we're either building Python or
+ # building an extension with an un-installed Python, so we use
+@@ -192,7 +192,7 @@
+ else:
+ # The name of the config.h file changed in 2.2
+ config_h = 'pyconfig.h'
+- return os.path.join(inc_dir, config_h)
++ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def get_makefile_filename():
+@@ -200,7 +200,7 @@
+ if python_build:
+ return os.path.join(os.path.dirname(sys.executable), "Makefile")
+ lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
+- return os.path.join(lib_dir, "config", "Makefile")
++ return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def parse_config_h(fp, g=None):
diff --git a/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch b/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch
new file mode 100644
index 0000000000..6beeb6e022
--- /dev/null
+++ b/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Python/compile.c
+===================================================================
+--- Python-2.5.1.orig/Python/compile.c
++++ Python-2.5.1/Python/compile.c
+@@ -30,7 +30,7 @@
+ #include "symtable.h"
+ #include "opcode.h"
+
+-int Py_OptimizeFlag = 0;
++int Py_OptimizeFlag = 1;
+
+ /*
+ ISSUES:
diff --git a/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch b/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
new file mode 100644
index 0000000000..54109afd62
--- /dev/null
+++ b/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line
++++ Python-2.4/Lib/distutils/command/build_scripts.py
+@@ -87,7 +87,7 @@
+ continue
+
+ match = first_line_re.match(first_line)
+- if match:
++ if False: #match:
+ adjust = 1
+ post_interp = match.group(1) or ''
+