summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-06-27 12:18:02 +0000
committerRichard Purdie <richard@openedhand.com>2007-06-27 12:18:02 +0000
commit9f15140b5de39adcc865732a9dd3c27c177adaf5 (patch)
tree35e743d12588ddd2d5da4f841e9fbc7380031566
parent14cb222ee2cec5874f700629ddaf263a8ed20b0f (diff)
downloadopenembedded-core-contrib-9f15140b5de39adcc865732a9dd3c27c177adaf5.tar.gz
Rename oh-image -> poky-image
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2020 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--README4
-rw-r--r--README.commands5
-rw-r--r--meta-extras/packages/images/poky-image-extras.bb (renamed from meta-extras/packages/images/oh-image-extras.bb)0
-rw-r--r--meta/packages/images/poky-image-base.bb (renamed from meta/packages/images/oh-image-base.bb)0
-rw-r--r--meta/packages/images/poky-image-core.bb (renamed from meta/packages/images/oh-image-core.bb)0
-rw-r--r--meta/packages/images/poky-image-minimal.bb (renamed from meta/packages/images/oh-image-minimal.bb)2
-rw-r--r--meta/packages/images/poky-image-sato-cd.bb (renamed from meta/packages/images/oh-cd-pda.bb)4
-rw-r--r--meta/packages/images/poky-image-sato.bb (renamed from meta/packages/images/oh-image-pda.bb)0
-rw-r--r--meta/packages/images/poky-image-sdk.bb (renamed from meta/packages/images/oh-image-sdk.bb)0
-rw-r--r--scripts/poky-qemu.README2
-rwxr-xr-xscripts/runqemu8
11 files changed, 15 insertions, 10 deletions
diff --git a/README b/README
index 1820eee536..fc435bd01a 100644
--- a/README
+++ b/README
@@ -44,13 +44,13 @@ Building An Image
Simply run;
% source poky-init-build-env
-% bitbake oh-image-pda
+% bitbake poky-image-sato
This will result in an ext2 image and kernel for qemu arm (see scripts dir).
To build for other machine types see MACHINE in build/conf/local.conf
-Other image targets such as oh-image-sdk or oh-image-core are available,
+Other image targets such as poky-image-sdk or poky-image-minimal are available,
see meta/packages/images/*.
Notes:
diff --git a/README.commands b/README.commands
index c3e0476d59..c84eefad99 100644
--- a/README.commands
+++ b/README.commands
@@ -77,6 +77,11 @@ can be useful for world or unattended builds.
The -s option lists all the versions of packages that bitbake will use.
+Bitbake - More Information
+==========================
+
+See the bitbake user manual at: http://bitbake.berlios.de/manual/
+
QEMU
====
diff --git a/meta-extras/packages/images/oh-image-extras.bb b/meta-extras/packages/images/poky-image-extras.bb
index d9b879683b..d9b879683b 100644
--- a/meta-extras/packages/images/oh-image-extras.bb
+++ b/meta-extras/packages/images/poky-image-extras.bb
diff --git a/meta/packages/images/oh-image-base.bb b/meta/packages/images/poky-image-base.bb
index 13545d9842..13545d9842 100644
--- a/meta/packages/images/oh-image-base.bb
+++ b/meta/packages/images/poky-image-base.bb
diff --git a/meta/packages/images/oh-image-core.bb b/meta/packages/images/poky-image-core.bb
index 431a1c583e..431a1c583e 100644
--- a/meta/packages/images/oh-image-core.bb
+++ b/meta/packages/images/poky-image-core.bb
diff --git a/meta/packages/images/oh-image-minimal.bb b/meta/packages/images/poky-image-minimal.bb
index 609db30728..29d442bf21 100644
--- a/meta/packages/images/oh-image-minimal.bb
+++ b/meta/packages/images/poky-image-minimal.bb
@@ -10,4 +10,4 @@ IMAGE_LINGUAS = " "
require poky-image.inc
# remove not needed ipkg informations
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files"
+ROOTFS_POSTPROCESS_COMMAND += "rm -rf ${IMAGE_ROOTFS}/usr/lib/ipkg/"
diff --git a/meta/packages/images/oh-cd-pda.bb b/meta/packages/images/poky-image-sato-cd.bb
index 7fa00cc637..dd882e7f88 100644
--- a/meta/packages/images/oh-cd-pda.bb
+++ b/meta/packages/images/poky-image-sato-cd.bb
@@ -1,11 +1,11 @@
DESCRIPTION = "Bootable CD"
-DEPENDS = "oh-image-pda"
+DEPENDS = "poky-image-sato"
COMPATIBLE_MACHINE = "bootcdx86"
IMAGE_NAME = "${PN}-${DATETIME}"
AUTO_SYSLINUXCFG = "1"
-INITRD = "${DEPLOY_DIR_IMAGE}/oh-image-pda-${MACHINE}.ext2"
+INITRD = "${DEPLOY_DIR_IMAGE}/oh-image-sato-${MACHINE}.ext2"
LABELS = "poky"
APPEND = "root=/dev/ram0"
diff --git a/meta/packages/images/oh-image-pda.bb b/meta/packages/images/poky-image-sato.bb
index 51632f6258..51632f6258 100644
--- a/meta/packages/images/oh-image-pda.bb
+++ b/meta/packages/images/poky-image-sato.bb
diff --git a/meta/packages/images/oh-image-sdk.bb b/meta/packages/images/poky-image-sdk.bb
index fd8fc272fc..fd8fc272fc 100644
--- a/meta/packages/images/oh-image-sdk.bb
+++ b/meta/packages/images/poky-image-sdk.bb
diff --git a/scripts/poky-qemu.README b/scripts/poky-qemu.README
index 3fbeb65029..e6d3c48a7b 100644
--- a/scripts/poky-qemu.README
+++ b/scripts/poky-qemu.README
@@ -39,7 +39,7 @@ where:
<zimage> is the path to a kernel (zimage-qemuarm.bin)
<filesystem> is the path to an ext2 image (filesystem-qemuarm.ext2)
-It will default to the qemuarm, ext2 and the last kernel and oh-image-sdk
+It will default to the qemuarm, ext2 and the last kernel and poky-image-sdk
image built by poky.
diff --git a/scripts/runqemu b/scripts/runqemu
index 42bcbca48f..a3bb777bbc 100755
--- a/scripts/runqemu
+++ b/scripts/runqemu
@@ -68,7 +68,7 @@ fi
if [ "$MACHINE" = "qemuarm" ]; then
if [ "$TYPE" = "ext2" ]; then
if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=$BUILDDIR/tmp/deploy/images/oh-image-sdk-qemuarm.ext2
+ HDIMAGE=$BUILDDIR/tmp/deploy/images/poky-image-sdk-qemuarm.ext2
fi
fi
fi
@@ -76,7 +76,7 @@ fi
if [ "$MACHINE" = "spitz" ]; then
if [ "$TYPE" = "ext3" ]; then
if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=$BUILDDIR/tmp/deploy/images/oh-image-pda-spitz.ext3
+ HDIMAGE=$BUILDDIR/tmp/deploy/images/poky-image-pda-spitz.ext3
fi
fi
fi
@@ -84,7 +84,7 @@ fi
if [ "$MACHINE" = "akita" ]; then
if [ "$TYPE" = "jffs2" ]; then
if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=$BUILDDIR/tmp/deploy/images/oh-image-pda-akita.jffs2
+ HDIMAGE=$BUILDDIR/tmp/deploy/images/poky-image-pda-akita.jffs2
fi
fi
fi
@@ -95,7 +95,7 @@ if [ "$MACHINE" = "qemux86" ]; then
fi
if [ "$TYPE" = "ext2" ]; then
if [ "x$HDIMAGE" = "x" ]; then
- HDIMAGE=$BUILDDIR/tmp/deploy/images/oh-image-sdk-qemux86.ext2
+ HDIMAGE=$BUILDDIR/tmp/deploy/images/poky-image-sdk-qemux86.ext2
fi
fi
CROSSPATH=$BUILDDIR/tmp/cross/i586-poky-linux/bin