summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-02-16 08:43:03 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-17 11:01:14 +0000
commitd13a1df7bd173fca3fc2cdf889d5eb487e35d6fd (patch)
tree06c543c62f47b94f548eedf0bca265b19ce51795
parent5a213506377b0db4e88ca094215eadf08c21a2e1 (diff)
downloadopenembedded-core-contrib-d13a1df7bd173fca3fc2cdf889d5eb487e35d6fd.tar.gz
acpica: Fix reproducibility issues
Fixes reproducibility when build acpica yacc sources by instructing bison on how to do the file prefix mapping Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/lib/oeqa/selftest/cases/reproducible.py1
-rw-r--r--meta/recipes-extended/acpica/acpica_20210105.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/lib/oeqa/selftest/cases/reproducible.py b/meta/lib/oeqa/selftest/cases/reproducible.py
index 32016f3e65..0963c2f11a 100644
--- a/meta/lib/oeqa/selftest/cases/reproducible.py
+++ b/meta/lib/oeqa/selftest/cases/reproducible.py
@@ -28,7 +28,6 @@ import datetime
# ruby-ri-docs, meson:
#https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20210215-0_td9la2/packages/diff-html/
exclude_packages = [
- 'acpica-src',
'babeltrace2-ptest',
'bootchart2-doc',
'cups',
diff --git a/meta/recipes-extended/acpica/acpica_20210105.bb b/meta/recipes-extended/acpica/acpica_20210105.bb
index 48b560db53..0188dc8a1b 100644
--- a/meta/recipes-extended/acpica/acpica_20210105.bb
+++ b/meta/recipes-extended/acpica/acpica_20210105.bb
@@ -34,6 +34,8 @@ EXTRA_OEMAKE = "CC='${CC}' \
PREFIX=${prefix} \
INSTALLDIR=${bindir} \
INSTALLFLAGS= \
+ YACC=bison \
+ YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
"
do_install() {