aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-11 11:00:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-11 11:11:26 +0000
commitb6d8f96ee51d8897e083974bd10d48f64ddffd32 (patch)
tree94c152d4472a0700c4d6755c09c289966454f023 /bitbake
parent20b4dcace222d6b1d659a8813b4affad075ec0c6 (diff)
downloadopenembedded-core-contrib-b6d8f96ee51d8897e083974bd10d48f64ddffd32.tar.gz
bitbake: bitbake/utils: Improve environment handling to allow UIs access to original environment
We need to empty out the environment whilst we build the cooker but we need the environment for the UIs since hob uses DISPLAY and other session variables. This patch adapts the utils functions to return removed environment components so we can reinject them for use by the UI, allowing hob to work again. (Bitbake rev: fc330d810099c57fefd4e706159a73ad8401d97c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake')
-rwxr-xr-xbitbake/bin/bitbake10
-rw-r--r--bitbake/lib/bb/utils.py10
2 files changed, 12 insertions, 8 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 89289050de..40b50e1688 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -229,10 +229,8 @@ Default BBFILES are the .bb files in the current directory.""")
# Before we start modifying the environment we should take a pristine
# copy for possible later use
initialenv = os.environ.copy()
- # Clear away any spurious environment variables. But don't wipe the
- # environment totally. This is necessary to ensure the correct operation
- # of the UIs (e.g. for DISPLAY, etc.)
- bb.utils.clean_environment()
+ # Clear away any spurious environment variables while we stoke up the cooker
+ cleanedvars = bb.utils.clean_environment()
server = server.BitBakeServer()
if configuration.bind:
@@ -258,6 +256,10 @@ Default BBFILES are the .bb files in the current directory.""")
# Setup a connection to the server (cooker)
server_connection = server.establishConnection()
+ # Restore the environment in case the UI needs it
+ for k in cleanedvars:
+ os.environ[k] = cleanedvars[k]
+
try:
return server.launchUI(ui_main, server_connection.connection, server_connection.events)
finally:
diff --git a/bitbake/lib/bb/utils.py b/bitbake/lib/bb/utils.py
index 484fb2dc76..b1a0f25e75 100644
--- a/bitbake/lib/bb/utils.py
+++ b/bitbake/lib/bb/utils.py
@@ -474,17 +474,17 @@ def filter_environment(good_vars):
are not known and may influence the build in a negative way.
"""
- removed_vars = []
+ removed_vars = {}
for key in os.environ.keys():
if key in good_vars:
continue
- removed_vars.append(key)
+ removed_vars[key] = os.environ[key]
os.unsetenv(key)
del os.environ[key]
if len(removed_vars):
- logger.debug(1, "Removed the following variables from the environment: %s", ", ".join(removed_vars))
+ logger.debug(1, "Removed the following variables from the environment: %s", ", ".join(removed_vars.keys()))
return removed_vars
@@ -509,7 +509,9 @@ def clean_environment():
"""
if 'BB_PRESERVE_ENV' not in os.environ:
good_vars = approved_variables()
- filter_environment(good_vars)
+ return filter_environment(good_vars)
+
+ return {}
def empty_environment():
"""