aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/dev-manual/dev-manual-common-tasks.xml
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-01-06 10:46:13 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-17 15:16:47 +0000
commit66ad91bd54d7a3ab0ea3948ac9bf42e3da53eadc (patch)
tree4f610d3e3e5fc46b596480f9955541e5d019b889 /documentation/dev-manual/dev-manual-common-tasks.xml
parentc8691a2d44a699a35bedddb940a5f3e70c11d7f4 (diff)
downloadopenembedded-core-contrib-66ad91bd54d7a3ab0ea3948ac9bf42e3da53eadc.tar.gz
dev-manual: Rewrite of the section on customizing images with packagegroups
This section was pointing to a poor example in meta. I substituted in a better example and rewrote the section to flow better around that example and the final fabricated one. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: c7f07a2993d5c1b8e0c8b7da0e9d4c28242a5e26) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/dev-manual/dev-manual-common-tasks.xml')
-rw-r--r--documentation/dev-manual/dev-manual-common-tasks.xml39
1 files changed, 27 insertions, 12 deletions
diff --git a/documentation/dev-manual/dev-manual-common-tasks.xml b/documentation/dev-manual/dev-manual-common-tasks.xml
index 9503593f61..17d725b3b8 100644
--- a/documentation/dev-manual/dev-manual-common-tasks.xml
+++ b/documentation/dev-manual/dev-manual-common-tasks.xml
@@ -1100,18 +1100,27 @@
an image is to create a custom package group recipe that is
used to build the image or images.
A good example of a package group recipe is
- <filename>meta/recipes-core/packagegroups/packagegroup-core-boot.bb</filename>.
- The
+ <filename>meta/recipes-core/packagegroups/packagegroup-base.bb</filename>.
+ </para>
+
+ <para>
+ If you examine that recipe, you see that the
<filename><ulink url='&YOCTO_DOCS_REF_URL;#var-PACKAGES'>PACKAGES</ulink></filename>
- variable lists the package group packages you wish to produce.
- <filename>inherit packagegroup</filename> sets appropriate
- default values and automatically adds <filename>-dev</filename>,
- <filename>-dbg</filename>, and <filename>-ptest</filename>
- complementary packages for every package specified in
- <filename>PACKAGES</filename>.
- Note that the inherit line should be towards
- the top of the recipe, certainly before you set
- <filename>PACKAGES</filename>.
+ variable lists the package group packages to produce.
+ The <filename>inherit packagegroup</filename> statement
+ sets appropriate default values and automatically adds
+ <filename>-dev</filename>, <filename>-dbg</filename>, and
+ <filename>-ptest</filename> complementary packages for each
+ package specified in the <filename>PACKAGES</filename>
+ statement.
+ <note>
+ The <filename>inherit packages</filename> should be
+ located near the top of the recipe, certainly before
+ the <filename>PACKAGES</filename> statement.
+ </note>
+ </para>
+
+ <para>
For each package you specify in <filename>PACKAGES</filename>,
you can use
<filename><ulink url='&YOCTO_DOCS_REF_URL;#var-RDEPENDS'>RDEPENDS</ulink></filename>
@@ -1119,7 +1128,13 @@
<filename><ulink url='&YOCTO_DOCS_REF_URL;#var-RRECOMMENDS'>RRECOMMENDS</ulink></filename>
entries to provide a list of packages the parent task package
should contain.
- Following is an example:
+ You can see examples of these further down in the
+ <filename>packagegroup-base.bb</filename> recipe.
+ </para>
+
+ <para>
+ Here is a short, fabricated example showing the same basic
+ pieces:
<literallayout class='monospaced'>
DESCRIPTION = "My Custom Package Groups"