aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2016-01-27 15:15:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 17:04:48 +0000
commit4f3ef90ae1db877541e7d3adee70228b0b7fa949 (patch)
treec18319e3ac37bd9beaef11490083cca7811a883e /documentation
parentb2b72143ab6f4c1e6b7935f233202ad221b373e2 (diff)
downloadopenembedded-core-contrib-4f3ef90ae1db877541e7d3adee70228b0b7fa949.tar.gz
ref-manual: Updated the BBMASK variable description.
(From yocto-docs rev: 0ae8d79993eef08c659e609af7e0afa09dcb9158) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/ref-manual/ref-variables.xml26
1 files changed, 10 insertions, 16 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 673e4314c4..49aea7a147 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -1200,17 +1200,13 @@
<glossentry id='var-BBMASK'><glossterm>BBMASK</glossterm>
<info>
- BBMASK[doc] = "Prevents BitBake from processing specific recipes or recipe append files. Use the BBMASK variable from within conf/local.conf."
+ BBMASK[doc] = "Prevents BitBake from processing specific recipes or recipe append files."
</info>
<glossdef>
<para role="glossdeffirst">
<!-- <para role="glossdeffirst"><imagedata fileref="figures/define-generic.png" /> -->
Prevents BitBake from processing recipes and recipe
append files.
- Use the <filename>BBMASK</filename> variable from within the
- <filename>conf/local.conf</filename> file found
- in the
- <ulink url='&YOCTO_DOCS_DEV_URL;#build-directory'>Build Directory</ulink>.
</para>
<para>
@@ -1218,14 +1214,14 @@
to "hide" these <filename>.bb</filename> and
<filename>.bbappend</filename> files.
BitBake ignores any recipe or recipe append files that
- match the expression.
+ match any of the expressions.
It is as if BitBake does not see them at all.
Consequently, matching files are not parsed or otherwise
used by BitBake.</para>
<para>
- The value you provide is passed to Python's regular
+ The values you provide are passed to Python's regular
expression compiler.
- The expression is compared against the full paths to
+ The expressions are compared against the full paths to
the files.
For complete syntax information, see Python's
documentation at
@@ -1241,18 +1237,16 @@
BBMASK = "meta-ti/recipes-misc/"
</literallayout>
If you want to mask out multiple directories or recipes,
- use the vertical bar to separate the regular expression
- fragments.
+ you can specify multiple regular expression fragments.
This next example masks out multiple directories and
individual recipes:
<literallayout class='monospaced'>
- BBMASK = "meta-ti/recipes-misc/|meta-ti/recipes-ti/packagegroup/"
- BBMASK .= "|.*meta-oe/recipes-support/"
- BBMASK .= "|.*openldap"
- BBMASK .= "|.*opencv"
- BBMASK .= "|.*lzma"
+ BBMASK += "/meta-ti/recipes-misc/ meta-ti/recipes-ti/packagegroup/"
+ BBMASK += "/meta-oe/recipes-support/"
+ BBMASK += "/meta-foo/.*/openldap"
+ BBMASK += "opencv.*\.bbappend"
+ BBMASK += "lzma"
</literallayout>
- Notice how the vertical bar is used to append the fragments.
<note>
When specifying a directory name, use the trailing
slash character to ensure you match just that directory