summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 03:48:37 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 03:48:37 +0000
commit6569da9da91f16411175110a69a9611d774fdc21 (patch)
tree68e8b10f0cadaa3fd95d8d12403b1b4325b98510 /meta-extras
parent5675f4056b8a59c6c984af68acd7c6de05db88be (diff)
downloadopenembedded-core-contrib-6569da9da91f16411175110a69a9611d774fdc21.tar.gz
zope: merged fixes from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4155 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/zope/zope_3.3.1.bb22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta-extras/packages/zope/zope_3.3.1.bb b/meta-extras/packages/zope/zope_3.3.1.bb
index 4c4664904c..6a6e283fca 100644
--- a/meta-extras/packages/zope/zope_3.3.1.bb
+++ b/meta-extras/packages/zope/zope_3.3.1.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
DEPENDS = "python"
RDEPENDS = "python-core python-shell"
LICENSE = "ZPL"
-PR = "r1"
+PR = "r3"
SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
@@ -18,12 +18,28 @@ do_compile() {
oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
}
+PYTHON_MAJMIN = "2.5"
+
do_install() {
+ install -d ${D}${libdir}/python${PYTHON_MAJMIN}
oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+ mv ${D}${libdir}/python/* ${D}${libdir}/python${PYTHON_MAJMIN}
}
-PACKAGES =+ "python-zopeinterface"
+PACKAGES =+ "python-zopeinterface python-zopeinterface-dbg"
FILES_${PN} = "${prefix}"
FILES_${PN}_doc = "${prefix}/doc"
-FILES_python-zopeinterface = "${libdir}/python/zope/interface/*.* ${libdir}/python/zope/interface/common"
+FILES_${PN}-dbg += "\
+${libdir}/python${PYTHON_MAJMIN}/BTrees/.debug \
+${libdir}/python${PYTHON_MAJMIN}/persistent/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/proxy/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/thread/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/security/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/hookable/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/app/container/.debug \
+${libdir}/python${PYTHON_MAJMIN}/zope/i18nmessageid/.debug \
+${libdir}/python${PYTHON_MAJMIN}/ZODB/.debug"
+FILES_python-zopeinterface-dbg += "${libdir}/python${PYTHON_MAJMIN}/zope/interface/.debug "
+
+FILES_python-zopeinterface = "${libdir}/python${PYTHON_MAJMIN}/zope/interface/*.* ${libdir}/python${PYTHON_MAJMIN}/zope/interface/common"