aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 13:05:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-24 00:11:32 +0000
commit673e2a05013cbe08efde936f663845031025689d (patch)
tree588ea9f4bec14df6127c13a79e556b1aa589ffb8 /meta/classes/autotools.bbclass
parentf775f76dc01f1a969c00f697507958d8a4f9b088 (diff)
downloadopenembedded-core-contrib-673e2a05013cbe08efde936f663845031025689d.tar.gz
autotools.bbclass: Make builds deterministic
We need to ensure any aclocal-copy directory is removed before we s earch for .m4 files, else the locations .m4 files are found from can vary depending on whether its the first or second time we run configure. Clearing any existing aclocal-copy directory before we start resolves this issue and makes builds deterministic again. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index e22ea6837f..a8d2b5f32e 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -102,6 +102,8 @@ autotools_do_configure() {
if [ -e ${S}/configure.in -o -e ${S}/configure.ac ]; then
olddir=`pwd`
cd ${S}
+ # Remove any previous copy of the m4 macros
+ rm -rf ${B}/aclocal-copy/
if [ x"${acpaths}" = xdefault ]; then
acpaths=
for i in `find ${S} -maxdepth 2 -name \*.m4|grep -v 'aclocal.m4'| \