aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2012-02-10 19:00:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:59:15 +0000
commitba175bdfe85d701298d28e5190e55207420a24e8 (patch)
treecc0efd2046cb3842fe272bb04547c838e0034229 /meta/classes
parentca343882f8e95b49b18b234000e387c879cf5885 (diff)
downloadopenembedded-core-contrib-ba175bdfe85d701298d28e5190e55207420a24e8.tar.gz
autotools.bbclass: Don't copy into non-existant directory
* If configure.ac contains AM_GNU_GETTEXT and po/Makefile.in.in doesn't exist, autotools_do_configure() copies a local version of Makefile.in.in to this location. If the directory 'po' doesn't exist, the function aborts. * This patch verifies that the directory exists before copying a file to it. This fixes libcddb, which uses AM_GNU_GETTEXT, but has no 'po' directory. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 5d743338fc..e22ea6837f 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -149,7 +149,7 @@ autotools_do_configure() {
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
# We'd call gettextize here if it wasn't so broken...
cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
- if [ ! -e ${S}/po/Makefile.in.in ]; then
+ if [ -d ${S}/po/ -a ! -e ${S}/po/Makefile.in.in ]; then
cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
fi
fi