aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/python/python/05-enable-ctypes-cross-build.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-06 05:07:49 -0700
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 22:05:20 -0700
commite18aba581c7f3f8518b8a9a850b6fe1eabc285ff (patch)
tree364264738a43168c79ba49402b0a7535e0a24ad8 /meta/packages/python/python/05-enable-ctypes-cross-build.patch
parent936a73eae5fd5732c9dc5ae2a47d6196f7f69c0a (diff)
downloadopenembedded-core-contrib-e18aba581c7f3f8518b8a9a850b6fe1eabc285ff.tar.gz
python: upgrade from 2.6.2 to 2.6.5
python-native: upgrade from 2.6.1 to 2.6.5 Also removed these older version files: python_2.5.2 python-native_2.5.1 Rebased the patches to the newer code. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/python/python/05-enable-ctypes-cross-build.patch')
-rw-r--r--meta/packages/python/python/05-enable-ctypes-cross-build.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/python/python/05-enable-ctypes-cross-build.patch b/meta/packages/python/python/05-enable-ctypes-cross-build.patch
new file mode 100644
index 0000000000..58b8078068
--- /dev/null
+++ b/meta/packages/python/python/05-enable-ctypes-cross-build.patch
@@ -0,0 +1,28 @@
+# CTypes need to know the actual host we are building on.
+# Signed-Off: Michael Dietrich <mdt@emdete.de>
+
+Index: Python-2.6.1/setup.py
+===================================================================
+--- Python-2.6.1.orig/setup.py
++++ Python-2.6.1/setup.py
+@@ -1656,16 +1656,16 @@ class PyBuildExt(build_ext):
+ ffi_configfile):
+ from distutils.dir_util import mkpath
+ mkpath(ffi_builddir)
+- config_args = []
++ config_args = ['--host=%s' % os.environ["HOST_SYS"], ]
+
+ # Pass empty CFLAGS because we'll just append the resulting
+ # CFLAGS to Python's; -g or -O2 is to be avoided.
+- cmd = "cd %s && env CFLAGS='' '%s/configure' %s" \
+- % (ffi_builddir, ffi_srcdir, " ".join(config_args))
++ cmd = "(cd %s && autoconf -W cross) && (cd %s && env CFLAGS='' '%s/configure' %s)" \
++ % (ffi_srcdir, ffi_builddir, ffi_srcdir, " ".join(config_args))
+
+ res = os.system(cmd)
+ if res or not os.path.exists(ffi_configfile):
+- print "Failed to configure _ctypes module"
++ print "Failed to configure _ctypes module (res=%d) or missing conffile=%s" % ( res, ffi_configfile )
+ return False
+
+ fficonfig = {}