summaryrefslogtreecommitdiffstats
path: root/meta/packages
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2010-08-13 11:35:26 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:20:11 +0100
commit070096ec70651cf28138167b8d33b67051b872ca (patch)
tree62d04c24767892dbfec99abf4739e923ed1b04ba /meta/packages
parent313bda1d8781f625ff157dc7e6b5ba62f494077a (diff)
downloadopenembedded-core-contrib-070096ec70651cf28138167b8d33b67051b872ca.tar.gz
runqemu-nfs: boot QEMU using nfsroot and local unfs export
This script automates the booting of QEMU using an nfsroot exported by our userspace NFS tools. The rootfs should be created using poky-extract-sdk. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/qemu/qemu-helper-nativesdk_1.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb b/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb
index 9c7f6ecbd3..473411db92 100644
--- a/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb
+++ b/meta/packages/qemu/qemu-helper-nativesdk_1.0.bb
@@ -13,6 +13,7 @@ SRC_URI = "file://${POKYBASE}/scripts/poky-qemu \
file://${POKYBASE}/scripts/poky-find-native-sysroot \
file://${POKYBASE}/scripts/poky-extract-sdk \
file://${POKYBASE}/scripts/poky-export-rootfs \
+ file://${POKYBASE}/scripts/runqemu-nfs \
file://tunctl.c \
file://raw2flash.c \
"
@@ -30,6 +31,7 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/
+ install -m 0755 ${WORKDIR}${POKYBASE}/scripts/runqemu-nfs ${D}${bindir}/
install tunctl ${D}${bindir}/
install raw2flash.spitz ${D}${bindir}/
install flash2raw.spitz ${D}${bindir}/