aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-0.97
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-06-29 20:32:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-29 15:02:13 +0100
commit909c8ff0f27064fd01853ef92977488e6a097dfe (patch)
treebfc0fc0b47995a9bd6a554891cb90e2bf2290a97 /meta/recipes-bsp/grub/grub-0.97
parent549929364cd7d29b50d8a4562c6f640e21a467f1 (diff)
downloadopenembedded-core-contrib-909c8ff0f27064fd01853ef92977488e6a097dfe.tar.gz
grub: add -fno-reorder-functions into STAGE2_COMPILE
This is used to work around a gcc-4.6's bug about the option. [YOCTO #1099] Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-0.97')
-rw-r--r--meta/recipes-bsp/grub/grub-0.97/no-reorder-functions.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-0.97/no-reorder-functions.patch b/meta/recipes-bsp/grub/grub-0.97/no-reorder-functions.patch
new file mode 100644
index 0000000000..70037e47c7
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub-0.97/no-reorder-functions.patch
@@ -0,0 +1,31 @@
+Upstream-Status: Inappropriate [disable feature]
+
+After the commit "tcmode-default: switch to gcc 4.6.0 for x86, x86-64 & arm",
+we got bug 1099 (http://bugzilla.yoctoproject.org/show_bug.cgi?id=1099):
+
+Running "install --stage2=/ssd/boot/grub/stage2 /boot/grub/stage1(hd0)
+ /boot/grub/stage2 p /boot/grub/menu list" failed
+Error 6: Mismatched or corrupt version of stage1/stage2
+
+This turned out to be a gcc's bug. See
+https://bugs.gentoo.org/show_bug.cgi?id=360513
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39333
+
+Upstream gcc seems uninterested in the bug, so at present we can disable the
+option as a workaround. Thanks Ryan Hill for the investigation and the
+workaround patch.
+
+Dexuan Cui <dexuan.cui@intel.com>
+Wed Jun 29 20:21:39 CST 2011
+
+--- grub-0.97/stage2/Makefile.am.orig
++++ grub-0.97/stage2/Makefile.am
+@@ -79,7 +79,7 @@
+ HERCULES_FLAGS =
+ endif
+
+-STAGE2_COMPILE = $(STAGE2_CFLAGS) -fno-builtin -nostdinc \
++STAGE2_COMPILE = $(STAGE2_CFLAGS) -fno-reorder-functions -fno-builtin -nostdinc \
+ $(NETBOOT_FLAGS) $(SERIAL_FLAGS) $(HERCULES_FLAGS)
+
+ STAGE1_5_LINK = -nostdlib -Wl,-N -Wl,-Ttext -Wl,2000