summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub-efi_2.04.bb
diff options
context:
space:
mode:
authorNorbert Kaminski <norbert.kaminski@3mdeb.com>2020-11-25 18:22:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-29 20:23:15 +0000
commit42ea75d441ae38cdffed3b1cd671af886c19fbb6 (patch)
tree6f7e9c4c53f2078ba78f275234d798cbfb646289 /meta/recipes-bsp/grub/grub-efi_2.04.bb
parent909bafef282f00dd4a83fab0569885e9788a4ed9 (diff)
downloadopenembedded-core-contrib-42ea75d441ae38cdffed3b1cd671af886c19fbb6.tar.gz
grub: Add support for RISC-V
This patch adds RISC-V to the COMPATIBLE_HOST. Since GRUB 2.04, the source code supports the RISC-V, thanks to Alexander Graf. Adding the GRUBPLATFORM for RISC-V prevents autoconf problems. Also, the patch appends the __anonymous method with RISC-V architecture. Signed-off-by: Norbert Kaminski <norbert.kaminski@3mdeb.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub-efi_2.04.bb')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.04.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.04.bb b/meta/recipes-bsp/grub/grub-efi_2.04.bb
index 30d95f95e0..f80afd95cb 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.04.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.04.bb
@@ -26,6 +26,10 @@ python __anonymous () {
grubtarget = 'arm64'
elif re.match('arm', target):
grubtarget = 'arm'
+ elif re.match('riscv64', target):
+ grubtarget = 'riscv64'
+ elif re.match('riscv32', target):
+ grubtarget = 'riscv32'
else:
raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
grubimage = prefix + d.getVar("EFI_BOOT_IMAGE")