aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/gummiboot
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-27 15:29:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-27 15:44:43 +0000
commite4fb1bdff543efa2a61ebac4a40e20bb5f121350 (patch)
tree7e39ffae6594ebb5117d27e4804076e152e473fb /meta/recipes-bsp/gummiboot
parent55de99100e1667c00fee7417b9ec4346accdc3f3 (diff)
downloadopenembedded-core-contrib-e4fb1bdff543efa2a61ebac4a40e20bb5f121350.tar.gz
gummiboot: fix the installed but not shipped warning
Fix the warning: WARNING: QA Issue: gummiboot: Files/directories were installed but not shipped /usr/lib /usr/lib/gummiboot /usr/lib/gummiboot/gummibootx64.efi This is because it uses "/usr/lib" in gummibootlibdir, use ${libdir} to fix it. (From OE-Core rev: ee587332f2ac9d88d4a300732645b0e2f793ce5f) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/gummiboot')
-rw-r--r--meta/recipes-bsp/gummiboot/gummiboot_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/gummiboot/gummiboot_git.bb b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
index 52a692b469..80df2b6ae3 100644
--- a/meta/recipes-bsp/gummiboot/gummiboot_git.bb
+++ b/meta/recipes-bsp/gummiboot/gummiboot_git.bb
@@ -26,6 +26,8 @@ EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \
--with-efi-ldsdir=${STAGING_LIBDIR} \
--with-efi-libdir=${STAGING_LIBDIR}"
+EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot"
+
do_deploy () {
install ${B}/gummiboot*.efi ${DEPLOYDIR}
}