aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot.inc
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-22 15:01:32 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-24 15:51:36 +0100
commit2e79fcd673dadeab6358fe22d47c8534c14de03e (patch)
treea4572afad7d3c8339f4f0c521ce3e86b84dfd1bc /meta/recipes-bsp/u-boot/u-boot.inc
parent2aefac2a2c508da11a73e29d82947ac627d31118 (diff)
downloadopenembedded-core-contrib-2e79fcd673dadeab6358fe22d47c8534c14de03e.tar.gz
u-boot.inc: fix compilation when using 'gold' as linker
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot.inc')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 0445c343d3..a13eddc829 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -36,6 +36,10 @@ SPL_IMAGE ?= "${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
do_compile () {
+ if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+ sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ fi
+
unset LDFLAGS
unset CFLAGS
unset CPPFLAGS