aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2015-07-31 13:21:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 15:15:12 +0100
commita1c83bb5556837d31d934b9af130cdbac19d5e97 (patch)
tree776bbc7f314f0c2852871476d6e2c589e6d115cb /meta/recipes-bsp
parentac4ef551d506a5767946cf2fb717c2fd7f86df9c (diff)
downloadopenembedded-core-contrib-a1c83bb5556837d31d934b9af130cdbac19d5e97.tar.gz
u-boot: fix extern inline build errors for gcc 5
The gcc 5 change its default standard from gnu89 to gnu11. These two standards do have different semantics for inline functions. And the gcc 5 will emit the following errors on the "extern inline" functions: arch/powerpc/cpu/mpc8xxx/fsl_lbc.o: In function `ld_le16': ./arch/powerpc/include/asm/byteorder.h:12: multiple definition of `ld_le16' arch/powerpc/cpu/mpc8xxx/fdt.o:./arch/powerpc/include/asm/byteorder.h:12: first defined here Fix these build errors by using "-fgnu89-inline" to enforce the gnu89 inline semantics as suggested in [1]. [1] https://gcc.gnu.org/gcc-5/porting_to.html Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2015.07.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot_2015.07.bb b/meta/recipes-bsp/u-boot/u-boot_2015.07.bb
index 3ba2f44eaa..4746c33ec2 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2015.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2015.07.bb
@@ -10,3 +10,5 @@ SRCREV = "33711bdd4a4dce942fb5ae85a68899a8357bdd94"
SRC_URI += "file://0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch"
PV = "v2015.07+git${SRCPV}"
+
+EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline"