summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-22 23:24:11 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-12 17:43:05 +0000
commit52af41387f1c843e7677c0bb632b2b96f9793ebd (patch)
tree4daca780fddc450fd5871a15fe33ce2a950fc236 /meta/recipes-connectivity/openssl
parent304417a97db89d9ea4a41aa7c92b5a052896d63b (diff)
downloadopenembedded-core-contrib-52af41387f1c843e7677c0bb632b2b96f9793ebd.tar.gz
openssl: Enable rc4/rc2/bf/md4 algorithms
They are still needed by several packages in meta-openembedded Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Shachar Menashe <shachar@vdoo.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1i.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1i.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1i.bb
index a82fd512ac..74ca11387a 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1i.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1i.bb
@@ -55,8 +55,15 @@ CFLAGS_append_class-native = " -DOPENSSLDIR=/not/builtin -DENGINESDIR=/not/built
CFLAGS_append_class-nativesdk = " -DOPENSSLDIR=/not/builtin -DENGINESDIR=/not/builtin"
# Disable deprecated crypto algorithms
-# Retained for compatibilty - des (curl), dh (python-ssl), dsa (rpm)
-DEPRECATED_CRYPTO_FLAGS = " no-ssl no-idea no-psk no-rc2 no-rc4 no-rc5 no-md2 no-md4 no-srp no-camellia no-bf no-mdc2 no-scrypt no-seed no-siphash no-sm2 no-sm3 no-sm4 no-whirlpool"
+# Retained for compatibilty
+# des (curl)
+# dh (python-ssl)
+# dsa (rpm)
+# md4 (cyrus-sasl freeradius hostapd)
+# bf (wvstreams postgresql x11vnc crda znc cfengine)
+# rc4 (freerdp librtorrent ettercap xrdp transmission pam-ssh-agent-auth php)
+# rc2 (mailx)
+DEPRECATED_CRYPTO_FLAGS = "no-ssl no-idea no-psk no-rc5 no-md2 no-srp no-camellia no-mdc2 no-scrypt no-seed no-siphash no-sm2 no-sm3 no-sm4 no-whirlpool"
do_configure () {
os=${HOST_OS}