summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ppp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 13:05:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 23:18:01 +0000
commit24f7351f6ac0408a1682893faf56b9145d698c1b (patch)
tree600ba06b8d0797098fd7f88739853a80994b94ab /meta/recipes-connectivity/ppp
parent11638ba4fa9f3d76cad2b46326792884ed488ecc (diff)
downloadopenembedded-core-contrib-24f7351f6ac0408a1682893faf56b9145d698c1b.tar.gz
ppp: Clean up PACKAGES vs. variable mismatch and drop unused RDEPENDS
The RPDEPENDS format is wrong and couldn't have been doing anything useful. The mismatch between PACKAGES and the DESCRIPTION_* and FILES_* variable names could confuse the system under certain conditions so this is a good cleanup to make. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/ppp')
-rw-r--r--meta/recipes-connectivity/ppp/ppp_2.4.5.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.5.bb b/meta/recipes-connectivity/ppp/ppp_2.4.5.bb
index 13216e3fdc..9232e6fdce 100644
--- a/meta/recipes-connectivity/ppp/ppp_2.4.5.bb
+++ b/meta/recipes-connectivity/ppp/ppp_2.4.5.bb
@@ -52,7 +52,7 @@ do_install_append () {
}
CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
-PACKAGES =+ "ppp-oa ppp-oe ppp-radius ppp-winbind ppp-minconn ppp-password ppp-l2tp ppp-tools"
+PACKAGES =+ "${PN}-oa ${PN}-oe ${PN}-radius ${PN}-winbind ${PN}-minconn ${PN}-password ${PN}-l2tp ${PN}-tools"
FILES_${PN} = "${sysconfdir} ${bindir} ${sbindir}/chat ${sbindir}/pppd"
FILES_${PN}_nylon = "${sysconfdir} ${bindir} ${sbindir}/chat ${sbindir}/pppd ${sbindir}/tdbread"
FILES_${PN}-dbg += "${libdir}/pppd/${PV}/.debug"
@@ -64,15 +64,14 @@ FILES_${PN}-minconn = "${libdir}/pppd/${PV}/minconn.so"
FILES_${PN}-password = "${libdir}/pppd/${PV}/pass*.so"
FILES_${PN}-l2tp = "${libdir}/pppd/${PV}/*l2tp.so"
FILES_${PN}-tools = "${sbindir}/pppstats ${sbindir}/pppdump"
-DESCRIPTION_ppp-oa = "Plugin for PPP needed for PPP-over-ATM"
-DESCRIPTION_ppp-oe = "Plugin for PPP needed for PPP-over-Ethernet"
-DESCRIPTION_ppp-radius = "Plugin for PPP that are related to RADIUS"
-DESCRIPTION_ppp-winbind = "Plugin for PPP to authenticate against Samba or Windows"
-DESCRIPTION_ppp-minconn = "Plugin for PPP to specify a minimum connect time before the idle timeout applies"
-DESCRIPTION_ppp-password = "Plugin for PPP to get passwords via a pipe"
-DESCRIPTION_ppp-l2tp = "Plugin for PPP for l2tp support"
-DESCRIPTION_ppp-tools = "The pppdump and pppstats utitilities"
-RDEPENDS_ppp_minconn += "libpcap0.8"
+DESCRIPTION_${PN}-oa = "Plugin for PPP needed for PPP-over-ATM"
+DESCRIPTION_${PN}-oe = "Plugin for PPP needed for PPP-over-Ethernet"
+DESCRIPTION_${PN}-radius = "Plugin for PPP that are related to RADIUS"
+DESCRIPTION_${PN}-winbind = "Plugin for PPP to authenticate against Samba or Windows"
+DESCRIPTION_${PN}-minconn = "Plugin for PPP to specify a minimum connect time before the idle timeout applies"
+DESCRIPTION_${PN}-password = "Plugin for PPP to get passwords via a pipe"
+DESCRIPTION_${PN}-l2tp = "Plugin for PPP for l2tp support"
+DESCRIPTION_${PN}-tools = "The pppdump and pppstats utitilities"
pkg_postinst_${PN}() {
if test "x$D" != "x"; then