aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-07-06 12:05:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-29 15:22:24 +0100
commit000da57cc858f5432153be849faba3862e4e9ed5 (patch)
tree8df651b0a87b94f576f57ccbb6a3837ffa51ee3c /meta/recipes-connectivity
parentfcea508efedeb36ca31fe8ad0cbc6d194fcfd1f7 (diff)
downloadopenembedded-core-contrib-000da57cc858f5432153be849faba3862e4e9ed5.tar.gz
openssl_1.1: avoid using += with an over-ride
Using += with an over-ride can be a source of confusion so try to avoid the construct in core recipes. The current usage is incorrect and prevents the aarch64 and musl specific config options from being active together. (From OE-Core rev: 2a30a9ecab6465892698f7fc9d14a430d8a26f0c) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.0h.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
index 29f83a31a2..64b8a997d0 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.0h.bb
@@ -126,12 +126,12 @@ do_configure () {
#| engines/afalg/e_afalg.c:110:20: error: '__NR_eventfd' undeclared (first use in this function)
#| return syscall(__NR_eventfd, n);
#| ^~~~~~~~~~~~
-EXTRA_OECONF_aarch64 += "no-afalgeng"
+EXTRA_OECONF_append_aarch64 = " no-afalgeng"
#| ./libcrypto.so: undefined reference to `getcontext'
#| ./libcrypto.so: undefined reference to `setcontext'
#| ./libcrypto.so: undefined reference to `makecontext'
-EXTRA_OECONF_libc-musl += "-DOPENSSL_NO_ASYNC"
+EXTRA_OECONF_append_libc-musl = " -DOPENSSL_NO_ASYNC"
do_install () {
oe_runmake DESTDIR="${D}" MANDIR="${mandir}" MANSUFFIX=ssl install