aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/bsd-headers/bsd-headers.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-08 09:05:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:30 +0000
commit06d020489dee672b1895f19c271eba4e17430106 (patch)
tree4b68d568fa629869baecbbf2a8d210cc476beebe /meta/recipes-core/bsd-headers/bsd-headers.bb
parentc2c92026e4e02364b84467464b5ff7411b771187 (diff)
downloadopenembedded-core-contrib-06d020489dee672b1895f19c271eba4e17430106.tar.gz
bsd-headers,musl: Add recipe for bsd missing features
let musl depend on these headers so they are staged along with libc (From OE-Core rev: 2cb184e4abaa69faad9f94631a3906188aa78e96) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/bsd-headers/bsd-headers.bb')
-rw-r--r--meta/recipes-core/bsd-headers/bsd-headers.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-core/bsd-headers/bsd-headers.bb b/meta/recipes-core/bsd-headers/bsd-headers.bb
new file mode 100644
index 0000000000..ae659abec4
--- /dev/null
+++ b/meta/recipes-core/bsd-headers/bsd-headers.bb
@@ -0,0 +1,25 @@
+# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "bsd compatible headers"
+LICENSE = "BSD-3-Clause && BSD-2-Clause"
+SECTION = "devel"
+
+SRC_URI = "file://sys-queue.h \
+ file://sys-tree.h \
+ "
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -Dm 0644 ${S}/sys-queue.h ${D}${includedir}/sys/queue.h
+ install -Dm 0644 ${S}/sys-tree.h ${D}${includedir}/sys/tree.h
+}
+#
+# We will skip parsing for non-musl systems
+#
+COMPATIBLE_HOST = ".*-musl.*"