aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.24.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-22 20:49:09 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-25 12:44:12 +0000
commitbe145ad5dc4edfd7dffc74b8970aaafd0eb247f7 (patch)
treee8994340c4b994e244344e35abe6112dcf075d8d /meta/recipes-core/busybox/busybox_1.24.1.bb
parent716fa93a8e0ce83bc602e53cf03b63c7966eaf4b (diff)
downloadopenembedded-core-contrib-be145ad5dc4edfd7dffc74b8970aaafd0eb247f7.tar.gz
busybox: Add support for busybox-init
in config metadata we can configure busybox based init and device initializer ( mdev ) using e.g. VIRTUAL-RUNTIME_dev_manager = "busybox-mdev" VIRTUAL-RUNTIME_login_manager = "busybox" VIRTUAL-RUNTIME_init_manager = "busybox" VIRTUAL-RUNTIME_initscripts = "initscripts" VIRTUAL-RUNTIME_keymaps = "keymaps" DISTRO_FEATURES_BACKFILL_CONSIDERED += "sysvinit" busybox can be used to provide init system combined with mdev it makes it a complete init system for really tiny systems. This patch uses above defines to configure features in busybox to enable the init system and mdev in a configurable manner (From OE-Core rev: 75cb4fe38fade382450c5f6f35d5dcf55962143e) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.24.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.24.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.24.1.bb b/meta/recipes-core/busybox/busybox_1.24.1.bb
index 5e19d9c605..8adee53911 100644
--- a/meta/recipes-core/busybox/busybox_1.24.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.24.1.bb
@@ -39,6 +39,12 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://sha256sum.cfg \
file://getopts.cfg \
file://resize.cfg \
+ ${@["", "file://init.cfg"][(d.getVar('VIRTUAL-RUNTIME_init_manager', True) == 'busybox')]} \
+ ${@["", "file://mdev.cfg"][(d.getVar('VIRTUAL-RUNTIME_dev_manager', True) == 'busybox-mdev')]} \
+ file://inittab \
+ file://rcS \
+ file://rcK \
+ file://runlevel \
"
SRC_URI_append_libc-musl = " file://musl.cfg "