summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.12.20.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-07-08 16:52:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-07-12 12:20:38 +0100
commitbfaef91e77cd54e4f642e966903aac3f3291c325 (patch)
tree460cd16552c28dca4ff505018d211c8b3eaf62a0 /meta/recipes-core/dbus/dbus-test_1.12.20.bb
parent4b2f45c47a5c8c800626f12c14f216a5ab923512 (diff)
downloadopenembedded-core-contrib-bfaef91e77cd54e4f642e966903aac3f3291c325.tar.gz
dbus: upgrade 1.12.18 -> 1.12.20
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.12.20.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.12.20.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.12.20.bb b/meta/recipes-core/dbus/dbus-test_1.12.20.bb
new file mode 100644
index 0000000000..755c841bad
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.12.20.bb
@@ -0,0 +1,64 @@
+SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
+HOMEPAGE = "http://dbus.freedesktop.org"
+SECTION = "base"
+
+require dbus.inc
+
+SRC_URI += "file://run-ptest \
+ file://python-config.patch \
+ "
+
+DEPENDS = "dbus glib-2.0"
+
+RDEPENDS_${PN}-dev = ""
+
+S="${WORKDIR}/dbus-${PV}"
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
+
+inherit ptest
+
+EXTRA_OECONF += "--enable-tests \
+ --enable-modular-tests \
+ --enable-installed-tests \
+ --enable-checks \
+ --enable-asserts \
+ --with-dbus-test-dir=${PTEST_PATH} \
+ --enable-embedded-tests \
+ "
+
+do_install() {
+ :
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ l="shell printf refs syslog marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay \
+ variant uid-permissions syntax spawn sd-activation names monitor message fdpass service shell-service"
+ for i in $l; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
+
+ l="bus bus-system bus-launch-helper"
+ for i in $l; do install ${B}/bus/.libs/test-$i ${D}${PTEST_PATH}/test; done
+
+ install -d ${D}${PTEST_PATH}/bus
+ install ${B}/bus/.libs/dbus-daemon-launch-helper-test ${D}${PTEST_PATH}/bus
+
+ install ${B}/test/test-segfault ${D}${PTEST_PATH}/test
+
+ cp -r ${B}/test/data ${D}${PTEST_PATH}/test
+ install ${B}/dbus/.libs/test-dbus ${D}${PTEST_PATH}/test
+
+ install -d ${D}${PTEST_PATH}/test/.libs
+ cp -a ${B}/dbus/.libs/*.so* ${D}${PTEST_PATH}/test/.libs
+
+ # Remove build host references...
+ find "${D}${PTEST_PATH}/test/data" \( -name *.service -o -name *.conf -o -name "*.aaprofile" \) -type f -exec \
+ sed -i \
+ -e 's:${B}:${PTEST_PATH}:g' \
+ {} +
+ sed -i -e 's;@PTEST_PATH@;${PTEST_PATH};g' ${D}${PTEST_PATH}/run-ptest
+}
+
+RDEPENDS_${PN}-ptest += "bash make dbus"
+RDEPENDS_${PN}-ptest_remove = "${PN}"
+
+PRIVATE_LIBS_${PN}-ptest = "libdbus-1.so.3"