aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus_1.8.20.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-01-04 10:08:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-11 23:26:31 +0000
commit3f4fb3936edbf42b6e94b71e0f243acd6c56b132 (patch)
treef325b575d077923990400b0660a2a8bf9c2d434d /meta/recipes-core/dbus/dbus_1.8.20.bb
parent0d5e41f41d28b6a7ce7468145fc86c59ecb424f9 (diff)
downloadopenembedded-core-contrib-3f4fb3936edbf42b6e94b71e0f243acd6c56b132.tar.gz
dbus: support large-file for stat64
While starting dbus-daemon on a 32-bit linux host and it invokes fstat to load /etc/dbus-1/system.conf through NFS. If system.conf was created with a large indoe number on 64-bit host. The above fstat invoking failed. Here is the log of strace: ............ $ ls -i /etc/dbus-1/system.conf 53778558109 /etc/dbus-1/system.conf $ strace /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation |open("/etc/dbus-1/system.conf", O_RDONLY) = 4 |fstat64(4, {st_mode=S_IFREG|0644, st_size=3340, ...}) = 0 |close(4) = 0 |close(3) = 0 |write(2, "Failed to start message bus: Fai"..., 109Failed to start message bus: Failed to stat "/etc/dbus-1/system.conf": Value too large for defined data type |) = 109 |exit_group(1) = ? |+++ exited with 1 +++ ............ In this situation, we should support large-file for stat64. Add marco AC_SYS_LARGEFILE to do the detection at configure time. It can be disabled by configuring with the `--disable-largefile' option. [YOCTO: #8863] (From OE-Core rev: 33a7a9b3efafc35ed1409fdfa8ab8f544f1babc3) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/dbus/dbus_1.8.20.bb')
-rw-r--r--meta/recipes-core/dbus/dbus_1.8.20.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus_1.8.20.bb b/meta/recipes-core/dbus/dbus_1.8.20.bb
index c0ad48b33c..0c7f6b1a21 100644
--- a/meta/recipes-core/dbus/dbus_1.8.20.bb
+++ b/meta/recipes-core/dbus/dbus_1.8.20.bb
@@ -17,6 +17,7 @@ SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
file://dbus-1.init \
file://os-test.patch \
file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
+ file://0001-configure.ac-support-large-file-for-stat64.patch \
"
SRC_URI[md5sum] = "b49890bbabedab3a1c3f4f73c7ff8b2b"
@@ -92,6 +93,7 @@ EXTRA_OECONF = "--disable-tests \
EXTRA_OECONF_append_class-native = " --disable-selinux"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
PACKAGECONFIG_class-native = ""
PACKAGECONFIG_class-nativesdk = ""
@@ -100,6 +102,7 @@ PACKAGECONFIG_class-nativesdk = ""
# systemd<->dbus
PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir"
PACKAGECONFIG[x11] = "--with-x --enable-x11-autolaunch,--without-x --disable-x11-autolaunch, virtual/libx11 libsm"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
do_install() {
autotools_do_install