aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-06-25 16:14:17 +0200
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:49:14 -0700
commit330d594af9f14faf0e5770b6056f4457a033fedd (patch)
treef604f9990ee250c5fd1ad991321bed0c906933ce /meta/recipes-core/dbus
parentd860ee68208b84efb8049669ca18acc69f2f2d1b (diff)
downloadopenembedded-core-contrib-330d594af9f14faf0e5770b6056f4457a033fedd.tar.gz
dbus-ptest: Install missing files
Install files from EXTRA_DIST needed for some tests. Add configure parameter with-dbus-test-dir to specify where the test tools are located. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/dbus')
-rw-r--r--meta/recipes-core/dbus/dbus-1.6.8/ptest.patch20
-rw-r--r--meta/recipes-core/dbus/dbus-ptest_1.6.8.bb1
2 files changed, 16 insertions, 5 deletions
diff --git a/meta/recipes-core/dbus/dbus-1.6.8/ptest.patch b/meta/recipes-core/dbus/dbus-1.6.8/ptest.patch
index 106bfb4c57..263d17eff7 100644
--- a/meta/recipes-core/dbus/dbus-1.6.8/ptest.patch
+++ b/meta/recipes-core/dbus/dbus-1.6.8/ptest.patch
@@ -76,7 +76,7 @@ diff -ur a/test/Makefile.am b/test/Makefile.am
$(NULL)
test_corrupt_SOURCES = corrupt.c
-@@ -325,3 +326,18 @@
+@@ -325,3 +325,25 @@
data/valid-config-files/system.conf: $(top_builddir)/bus/system.conf
$(AM_V_at)$(MKDIR_P) data/valid-config-files
$(AM_V_GEN)cp $< $@
@@ -91,26 +91,36 @@ diff -ur a/test/Makefile.am b/test/Makefile.am
+
+install-ptest-nonrecursive:
+ @$(MKDIR_P) $(DESTDIR)/data/valid-config-files/session.d
-+ @for file in Makefile $(installable_tests) $(EXTRA_DIST) $(noinst_DATA); do \
-+ install -D $${file%.in} $(DESTDIR)/$${file%.in}; \
++ @for file in Makefile $(installable_tests) $(noinst_PROGRAMS) $(noinst_DATA) ; do \
++ if [ -f .libs/$$file ]; then \
++ install .libs/$$file $(DESTDIR); \
++ else \
++ install -D $${file%.in} $(DESTDIR)/$${file%.in}; \
++ fi; \
++ done;
++ @for file in $(EXTRA_DIST); do \
++ install -D ${srcdir}/$${file%.in} $(DESTDIR)/$${file%.in}; \
+ done;
+endif
diff -ur a/test/name-test/Makefile.am b/test/name-test/Makefile.am
--- a/test/name-test/Makefile.am 2012-12-06 14:34:01.169413931 +0100
+++ b/test/name-test/Makefile.am 2012-12-06 15:21:14.459112518 +0100
-@@ -36,4 +36,13 @@
+@@ -36,4 +36,16 @@
test_privserver_client_LDADD=../libdbus-testutils.la
test_autolaunch_LDADD=../libdbus-testutils.la
+install-ptest:
+ @$(MKDIR_P) $(DESTDIR)
-+ @for file in Makefile $(noinst_PROGRAMS) $(EXTRA_DIST); do \
++ @for file in Makefile $(noinst_PROGRAMS); do \
+ if [ -f .libs/$$file ]; then \
+ install .libs/$$file $(DESTDIR); \
+ else \
+ install $$file $(DESTDIR); \
+ fi \
+ done;
++ @for file in $(EXTRA_DIST); do \
++ cp $(srcdir)/$$file $(DESTDIR); \
++ done;
endif
diff -ur a/tools/Makefile.am b/tools/Makefile.am
--- a/tools/Makefile.am 2012-12-06 14:34:01.161414276 +0100
diff --git a/meta/recipes-core/dbus/dbus-ptest_1.6.8.bb b/meta/recipes-core/dbus/dbus-ptest_1.6.8.bb
index d00819a8dc..8d21666c57 100644
--- a/meta/recipes-core/dbus/dbus-ptest_1.6.8.bb
+++ b/meta/recipes-core/dbus/dbus-ptest_1.6.8.bb
@@ -38,6 +38,7 @@ EXTRA_OECONF = "--enable-tests \
--disable-libaudit \
--with-xml=expat \
--with-systemdsystemunitdir=${systemd_unitdir}/system/ \
+ --with-dbus-test-dir=${PTEST_PATH} \
${EXTRA_OECONF_X}"
do_install() {