aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-13 07:02:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:35:24 +0000
commitcd91b748e83bd5c040538aecf76823549662b3c7 (patch)
tree1126142d13106be48185dc7cda8d24f648fc2b2a /meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
parentf813c09493ddad2df5b18b3b3b5c44d5b4201b72 (diff)
downloadopenembedded-core-contrib-cd91b748e83bd5c040538aecf76823549662b3c7.tar.gz
gettext: upgrade to 0.19.4
* gettext: - Update parallel.patch, we only need a part of it. * gettext-minimal-native: - Update related files from gettext-native. - Remove Makevars.template, we didn't use it. - Remove iconv-m4-remove-the-test-to-convert-euc-jp.patch (can be reverse applied). - Update the COPYING (1995 - 2014). * About upgrade gettext-minimal-native (for future's upgrade): - Build gettext-native - Copy gettext-runtime/po/Makefile.in.in, build-aux/config.rpath and gettext-runtime/po/remove-potcdate.sin from gettext-native. - Update COPYING when needed (usually update the year), do not copy the whole COPYING file from gettext-native. - Go to gettext-native's ${S}/gettext-runtime/m4: > Remove lt*.m4 and libtool.m4 > copy lib-ld.m4 lib-link.m4 lib-prefix.m4 from ${S}/gettext-runtime/m4/ > tar czvf /path/to/aclocal.tgz *.m4 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
new file mode 100644
index 0000000000..ca97315a85
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.19.4.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Minimal gettext for supporting native autoconf/automake"
+DESCRIPTION = "Contains the m4 macros sufficient to support building \
+autoconf/automake. This provides a significant build time speedup by \
+the removal of gettext-native from most dependency chains (now only \
+needed for gettext for the target)."
+SRC_URI = "file://aclocal.tgz \
+ file://config.rpath \
+ file://Makefile.in.in \
+ file://remove-potcdate.sin \
+ file://COPYING \
+"
+
+INHIBIT_DEFAULT_DEPS = "1"
+INHIBIT_AUTOTOOLS_DEPS = "1"
+
+LICENSE = "FSF-Unlimited"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1b20675cd5158442f6007d022f46b35b"
+
+inherit native
+
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${datadir}/aclocal/
+ cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
+ install -d ${D}${datadir}/gettext/po/
+ cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
+ cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
+ cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
+}