summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-09-28 17:18:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-30 15:01:46 +0100
commit6ba3e164d7afb69bddd546957331d0de7cb0a10b (patch)
treeb9fc17ee8a02c1f7abbdb1798904e52fc959ba29 /meta/recipes-core/glibc
parent5de83bbd7c55a63cbee88a3fb983c0889036a248 (diff)
downloadopenembedded-core-contrib-6ba3e164d7afb69bddd546957331d0de7cb0a10b.tar.gz
glibc: make nscd optional
NSCD itself is already packaged into its own package, but if it is never going to be needed then it can be disabled and it won't be called from glibc at all. Add a PACKAGECONFIG for NSCD that is enabled by default. As a side effect if NSCD is disable, glibc with and without systemd is binary identical, which helps sstate reuse. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.32.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.32.bb b/meta/recipes-core/glibc/glibc_2.32.bb
index 7049e61625..2a0e464385 100644
--- a/meta/recipes-core/glibc/glibc_2.32.bb
+++ b/meta/recipes-core/glibc/glibc_2.32.bb
@@ -69,13 +69,15 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
--enable-stackguard-randomization \
--disable-crypt \
--with-default-link \
- --enable-nscd \
${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
${GLIBCPIE} \
${GLIBC_EXTRA_OECONF}"
EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
+PACKAGECONFIG ??= "nscd"
+PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
+
do_patch_append() {
bb.build.exec_func('do_fix_readlib_c', d)
}