aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-22 17:43:33 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-02 05:52:06 -0700
commitad23395cd1f6c0cbfcc6980b6071d589f9f6cde0 (patch)
tree9965e27a93c73af1ccf9cdb24c588faabc90370a /meta/recipes-core/meta
parent58a8a38aa294edb74dde70d70a7e5faf49444b78 (diff)
downloadopenembedded-core-contrib-ad23395cd1f6c0cbfcc6980b6071d589f9f6cde0.tar.gz
nativesdk: Switch to using nativesdk as a prefix, not a suffix
As discussed on the mailing lists, using a suffix to package names is hard and has lead to many recipes having to do PKGSUFFIX games. Its looking extremely hard to scale nativesdk much further without hacking many recipes. By comparison, using a prefix like multilib does works much better and doesn't involve "hacking" as many recipes. This change converts nativesdk to use a prefix using the existing multilib infrastructure. (From OE-Core rev: 81813c0e322dc04ce4b069117188d8a54dfddb8c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/external-python-tarball.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/meta/recipes-core/meta/external-python-tarball.bb b/meta/recipes-core/meta/external-python-tarball.bb
index e317ba32ca..2085acc223 100644
--- a/meta/recipes-core/meta/external-python-tarball.bb
+++ b/meta/recipes-core/meta/external-python-tarball.bb
@@ -16,25 +16,25 @@ SDK_DEPLOY = "${TMPDIR}/deploy/sdk"
IPKG_HOST = "opkg-cl -f ${IPKGCONF_SDK} -o ${SDK_OUTPUT}"
TOOLCHAIN_HOST_TASK ?= "\
- python-nativesdk-core \
- python-nativesdk-textutils \
- python-nativesdk-sqlite3 \
- python-nativesdk-pickle \
- python-nativesdk-logging \
- python-nativesdk-elementtree \
- python-nativesdk-curses \
- python-nativesdk-compile \
- python-nativesdk-compiler \
- python-nativesdk-fcntl \
- python-nativesdk-shell \
- python-nativesdk-misc \
- python-nativesdk-multiprocessing \
- python-nativesdk-subprocess \
- python-nativesdk-xmlrpc \
- python-nativesdk-netclient \
- python-nativesdk-netserver \
- python-nativesdk-distutils \
- chrpath-nativesdk \
+ nativesdk-python-core \
+ nativesdk-python-textutils \
+ nativesdk-python-sqlite3 \
+ nativesdk-python-pickle \
+ nativesdk-python-logging \
+ nativesdk-python-elementtree \
+ nativesdk-python-curses \
+ nativesdk-python-compile \
+ nativesdk-python-compiler \
+ nativesdk-python-fcntl \
+ nativesdk-python-shell \
+ nativesdk-python-misc \
+ nativesdk-python-multiprocessing \
+ nativesdk-python-subprocess \
+ nativesdk-python-xmlrpc \
+ nativesdk-python-netclient \
+ nativesdk-python-netserver \
+ nativesdk-python-distutils \
+ nativesdk-chrpath \
"
TOOLCHAIN_OUTPUTNAME ?= "python-nativesdk-standalone-${SDKMACHINE}"