summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/gcompat_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-12 12:43:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-14 15:05:08 +0100
commit5efe7c06c8555672b535adae587596f65bff4fc5 (patch)
tree1e46cf3cedf8a5124582ad6a494083f1562f6455 /meta/recipes-core/musl/gcompat_git.bb
parent75110a9cc5e6840c65ed24bcca7d4cf1748ab67d (diff)
downloadopenembedded-core-contrib-5efe7c06c8555672b535adae587596f65bff4fc5.tar.gz
gcompat: Add recipe
This is a compat library which helps running pre-compiled binaries which were compiled for glibc but needs to run on musl systems, this is quite common case where pre-existing binaries are supplied and can not be recompiled immediately Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/gcompat_git.bb')
-rw-r--r--meta/recipes-core/musl/gcompat_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/gcompat_git.bb b/meta/recipes-core/musl/gcompat_git.bb
new file mode 100644
index 0000000000..6792c0be70
--- /dev/null
+++ b/meta/recipes-core/musl/gcompat_git.bb
@@ -0,0 +1,42 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "A library which provides glibc-compatible APIs for use on musl libc systems"
+HOMEPAGE = "https://git.adelielinux.org/adelie/gcompat"
+
+LICENSE = "NCSA"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eb33ef4af05a9c7602843afb7adfe792"
+
+SRC_URI = "git://git.adelielinux.org/adelie/gcompat.git;protocol=https;branch=current"
+
+PV = "1.0.0+1.1+git${SRCPV}"
+SRCREV = "af5a49e489fdc04b9cf02547650d7aeaccd43793"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig linuxloader
+
+DEPENDS += "musl-obstack"
+
+GLIBC_LDSO = "${@get_glibc_loader(d)}"
+MUSL_LDSO = "${@get_musl_loader(d)}"
+
+EXTRA_OEMAKE = "LINKER_PATH=${MUSL_LDSO} LOADER_NAME=`basename ${@get_glibc_loader(d)}`"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install 'DESTDIR=${D}'
+}
+#
+# We will skip parsing for non-musl systems
+#
+COMPATIBLE_HOST = ".*-musl.*"
+
+UPSTREAM_CHECK_COMMITS = "1"