aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/musl_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-10 21:00:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:31 +0000
commit29deaf0a402e8236c3749067387ce4117937ac13 (patch)
tree0b0bc765317090c4357223b8cb36ba9b53904877 /meta/recipes-core/musl/musl_git.bb
parent2d028b382c234c23cb54f3eb33e70b3c248d9128 (diff)
downloadopenembedded-core-contrib-29deaf0a402e8236c3749067387ce4117937ac13.tar.gz
musl: Create ld.so as a relative symlink
We have rootfs intercepts which fail on musl because ld.so on musl is an absolute symlink to /usr/lib/libc.so and then it fails to load when run with qemu user mode. Fixes rootfs failures like WARNING: The postinstall intercept hook 'update_pixbuf_cache' failed (exit code: 255)! See log for details! WARNING: The postinstalls for the following packages will be postponed for first boot: libgdk-pixbuf-2.0-loader-jpeg li bgdk-pixbuf-2.0-loader-png libgdk-pixbuf-2.0-loader-gif libgdk-pixbuf-2.0-loader-xpm WARNING: [log_check] core-image-sato: found a warning message in the logfile (keyword 'WARNING:'): [log_check] WARNING: The postinstall intercept hook 'update_pixbuf_cache' failed (exit code: 255)! See log for details! WARNING: [log_check] core-image-sato: found a warning message in the logfile (keyword 'WARNING:'): [log_check] WARNING: The postinstalls for the following packages will be postponed for first boot: libgdk-pixbuf-2.0-lo ader-jpeg libgdk-pixbuf-2.0-loader-png libgdk-pixbuf-2.0-loader-gif libgdk-pixbuf-2.0-loader-xpm (From OE-Core rev: d48ea3354eff8244e1734fa571bb52c810431b3f) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl/musl_git.bb')
-rw-r--r--meta/recipes-core/musl/musl_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 5b94d1fe28..8970307cba 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -10,6 +10,7 @@ PV = "1.1.12+git${SRCPV}"
# mirror is at git://github.com/kraj/musl.git
SRC_URI = "git://git.musl-libc.org/musl \
+ file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
"
S = "${WORKDIR}/git"
@@ -49,7 +50,7 @@ do_install() {
oe_runmake install DESTDIR='${D}'
install -d ${D}${bindir}
- ln -s ${libdir}/libc.so ${D}${bindir}/ldd
+ ln -s ../../${libdir}/libc.so ${D}${bindir}/ldd
}
RDEPENDS_${PN}-dev = "linux-libc-headers-dev"