aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-03 15:09:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-03 11:09:07 +0100
commit9105e9e3c498d1a9552bc98ce1003cd0afc615c0 (patch)
tree783d5bc499efd4dc721be3f1f60317f7103a41f5 /meta/recipes-core/psplash
parent2caee0c68aa438c21aaf514428a0ada771757b58 (diff)
downloadopenembedded-core-contrib-9105e9e3c498d1a9552bc98ce1003cd0afc615c0.tar.gz
psplash: mask psplash in case of systemd
We need to prevent the psplash init script from running via systemd because the script is supposed to be used by sysvinit system and it doesn't have any real effect in a systemd based system. (From OE-Core rev: 2e847db3ac3333a68b721b11624f4f515bda7ccf) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 628ced4d49..4e8f071a8e 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -109,3 +109,13 @@ FILES_${PN} += "/mnt/.psplash"
INITSCRIPT_NAME = "psplash.sh"
INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
+
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+pkg_postinst_${PN} () {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ if [ -n "$D" ]; then
+ OPTS="--root=$D"
+ fi
+ systemctl $OPTS mask psplash.service
+ fi
+}