aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-03 16:52:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-06 15:06:31 +0100
commit0038634ee6e2b6035c023a2702547f20f67c103a (patch)
treeb8231a383c167f0e71be74a75719fb9ff10efbb3 /meta/recipes-core
parent112641117f1152bad8a806f1aa872a67575d5316 (diff)
downloadopenembedded-core-contrib-0038634ee6e2b6035c023a2702547f20f67c103a.tar.gz
meta-environment: Deal with machines which change TARGET_OS
Some machines change TARGET_OS, cross-canadian resets this which is not what we want in this specific case. This fixes spe toolchains for example. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/meta-environment.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/meta-environment.bb b/meta/recipes-core/meta/meta-environment.bb
index cf1a83f8f8..9d8bcb71de 100644
--- a/meta/recipes-core/meta/meta-environment.bb
+++ b/meta/recipes-core/meta/meta-environment.bb
@@ -6,7 +6,9 @@ PR = "r8"
EXCLUDE_FROM_WORLD = "1"
-REAL_MULTIMACH_TARGET_SYS = "${TUNE_PKGARCH}${TARGET_VENDOR}-${TARGET_OS}"
+ORIGOS := "${TARGET_OS}"
+
+REAL_MULTIMACH_TARGET_SYS = "${TUNE_PKGARCH}${TARGET_VENDOR}-${ORIGOS}"
inherit toolchain-scripts
TOOLCHAIN_NEED_CONFIGSITE_CACHE += "zlib"
@@ -29,6 +31,7 @@ python do_generate_content() {
# make sure we only use the SDKTARGETSYSROOT value from 'd'
localdata.setVar('SDKTARGETSYSROOT', d.getVar('SDKTARGETSYSROOT', True))
+ localdata.setVar('TARGET_OS', d.getVar('ORIGOS', True))
localdata.setVar('libdir', d.getVar('target_libdir', False))
# Process DEFAULTTUNE