aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-02-11 16:08:06 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-11 22:33:40 +0000
commit9a6cb10d4a611ed64700f9e9240c2958db7e2234 (patch)
tree1c04a54243fc95d00b3f46b4ffbbe80046a9b95e /meta/recipes-core
parent5e978d7ed89fe028a8d01221bcda7f9edca35d08 (diff)
downloadopenembedded-core-contrib-9a6cb10d4a611ed64700f9e9240c2958db7e2234.tar.gz
nativesdk-buildtools-perl-dummy.bb: Fix variable expansion in python code
Since python expansion of bb data variables is disable in order to provide a standard interface usage for expand variables this variables aren't expanded now so change to call d.expand('${VAR}'). This API expansion change was causing to install perl in nativesdk. (From OE-Core rev: cb7a3f997d7278eb6e31ea79ad933a7ab1717977) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
index 9041734898..90784a9e27 100644
--- a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -20,7 +20,7 @@ PERLPACKAGES = "nativesdk-perl \
ALLOW_EMPTY_${PN} = "1"
python populate_packages_prepend() {
- d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
- d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
+ d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
+ d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
}