aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-13 11:16:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 11:21:58 +0000
commit9f551d588693328e4d99d33be94f26684eafcaba (patch)
treeb4dbecbe33c08a93252e000a88c363b839721b58 /meta/recipes-core
parentb020a7139a6fd9efd052a3dc3c02a41f621ae952 (diff)
downloadopenembedded-core-contrib-9f551d588693328e4d99d33be94f26684eafcaba.tar.gz
meta: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple attempts at doing so (or simply have re-appeared?). Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_239.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_239.bb b/meta/recipes-core/systemd/systemd-boot_239.bb
index 312a0145d8..2450d52cb9 100644
--- a/meta/recipes-core/systemd/systemd-boot_239.bb
+++ b/meta/recipes-core/systemd/systemd-boot_239.bb
@@ -29,7 +29,7 @@ EXTRA_OEMESON += "-Defi=true \
python __anonymous () {
import re
target = d.getVar('TARGET_ARCH')
- prefix = "" if d.getVar('EFI_PROVIDER', True) == "systemd-boot" else "systemd-"
+ prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
if target == "x86_64":
systemdimage = prefix + "bootx64.efi"
else: