aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-01-02 11:29:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:40 +0000
commit8eb45acf307e5f30678b4725969e03b5e3f52b4e (patch)
treea0c47ab7f068a3db1734c8993f50fc27e966974a /meta/recipes-devtools/btrfs-tools/btrfs-tools
parent761acbb4fa3ec8bec8e099e544495280a950e1de (diff)
downloadopenembedded-core-contrib-8eb45acf307e5f30678b4725969e03b5e3f52b4e.tar.gz
btrfs-tools:Fix multithreaded building
Fixes bug: [YOCTO #1524] Fixes this error with make -j: btrfsctl.c | i586-poky-linux-gcc -m32 -march=i586 --sysroot=/intel/poky/builds/world/tmp/sysroots/qemux86 -Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c btrfsctl.c | btrfsctl.c:37:21: fatal error: version.h: No such file or directory | compilation terminated. | btrfslabel.c:40:21: fatal error: version.h: No such file or directory | compilation terminated. (From OE-Core rev: 3ebc06c2f011da95fd6bed74c9e27b2148011ee7) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch
new file mode 100644
index 0000000000..40175b8ffa
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools/fix_race_condition_with_multithreaded_make.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Pending
+
+Fix makefile for multithreaded (make -j ) building.
+
+btrfsctl.c
+| i586-poky-linux-gcc -m32 -march=i586 --sysroot=/intel/poky/builds/world/tmp/sysroots/qemux86 -Wp,-MMD,./.btrfsctl.o.d,-MT,btrfsctl.o -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -O2 -pipe -g -feliminate-unused-debug-types -c btrfsctl.c
+| btrfsctl.c:37:21: fatal error: version.h: No such file or directory
+| compilation terminated.
+| btrfslabel.c:40:21: fatal error: version.h: No such file or directory
+| compilation terminated.
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/01/02
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -26,14 +26,13 @@ else
+ check = ls
+ endif
+
+-.c.o:
++%.o: %.c version.h
+ $(check) $<
+ $(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
+
++all: $(progs) manpages
+
+-all: version $(progs) manpages
+-
+-version:
++version.h: version.sh
+ bash version.sh
+
+ btrfs: $(objects) btrfs.o btrfs_cmds.o scrub.o